Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Ibrahim Ahmed Badr 4 posts 24 karma points
    Feb 23, 2022 @ 09:27
    Ibrahim Ahmed Badr

    Appreciate your urgently support to solve this issue, I'm working with SQLCE I just migrated my website and It failed to boot after the installation process I'm hosting locally now but I'm planning to use TMD hosting, I've tried several solutions but It doesn't work, I'm not sure what causes this

        "@t": "2022-02-23T08:56:16.0195316Z",
        "@mt": "{FailMessage} ({Duration}ms) [Timing {TimingId}]",
        "@l": "Error",
        "@x": "Umbraco.Core.Exceptions.BootFailedException: Boot failed. ---> System.TimeoutException: Cannot acquire MainDom\r\n at Umbraco.Core.Runtime.MainDom.Acquire() in D:\a\1\s\src\Umbraco.Core\Runtime\MainDom.cs:line 172\r\n at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)\r\n at Umbraco.Core.Runtime.MainDom.get_IsMainDom() in D:\a\1\s\src\Umbraco.Core\Runtime\MainDom.cs:line 211\r\n at Umbraco.Core.Runtime.CoreRuntime.AcquireMainDom(IMainDom mainDom) in D:\a\1\s\src\Umbraco.Core\Runtime\CoreRuntime.cs:line 471\r\n at Umbraco.Core.Runtime.CoreRuntime.Boot(IRegister register, DisposableTimer timer) in D:\a\1\s\src\Umbraco.Core\Runtime\CoreRuntime.cs:line 183\r\n --- End of inner exception stack trace ---",
        "FailMessage": "Boot failed.",
        "Duration": 53319,
        "TimingId": "5f5a93d",
        "SourceContext": "Umbraco.Core.Runtime.CoreRuntime",
        "ProcessId": 10540,
        "ProcessName": "w3wp",
        "ThreadId": 23,
        "AppDomainId": 7,
        "AppDomainAppId": "LMW3SVC4ROOT",
        "MachineName": "IBRAHIMOGOD-5D-",
        "Log4NetLevel": "ERROR",
        "HttpRequestNumber": 1,
        "HttpRequestId": "05a5a968-d1fa-4e94-80ef-5187372ff814"

    Boot Failed Umbraco failed to boot, if you are the owner of the website please see the log file for more details.

  • Damien Holley 175 posts 535 karma points
    Aug 31, 2022 @ 22:37
    Damien Holley

    Do you have a load-balanced setup?

    I am having this issue on public instances on an Azure load-balanced instance.

  • Damien Holley 175 posts 535 karma points
    May 10, 2023 @ 01:12
    Damien Holley

    My solution in this instance was some custom indexers/searchers were trying to run prior to the index being built and were throwing an exception, this then stopped the boot process entirely.

    I added the runtimelevel attribute and had the setup for the custom indexes run on 'run'. This solved the majority of boot issues.

Please Sign in or register to post replies

Write your reply to: