Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Bram van den Bogaard 3 posts 23 karma points
    3 days ago
    Bram van den Bogaard
    0

    Error during Installation: Transaction has completed, it is no longer usable (V10)

    Hi everyone, I've ran into an issue unfortunately. I created a new database for Umbraco 10 but when running the installer I get an error that is not known to me and the "fixes" found online (restarting database, creating a new one from scratch etc.) are not working. The error happens during the ZombieCheck on the database.

    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation.\r\n ---> System.InvalidOperationException: This SqlTransaction has completed; it is no longer usable.\r\n at Microsoft.Data.SqlClient.SqlTransaction.ZombieCheck()\r\n at Microsoft.Data.SqlClient.SqlTransaction.Commit()\r\n at NPoco.Database.CompleteTransaction()\r\n at Umbraco.Cms.Infrastructure.Scoping.Scope.DisposeLastScope()\r\n at Umbraco.Cms.Infrastructure.Scoping.Scope.Dispose()\r\n at Umbraco.Cms.Infrastructure.Migrations.Install.DatabaseBuilder.CreateSchemaAndData()\r\n at Umbraco.Cms.Infrastructure.Install.InstallSteps.DatabaseInstallStep.ExecuteAsync(Object model)\r\n --- End of inner exception stack trace ---\r\n at System.RuntimeMethodHandle.InvokeMethod(Object target, Span 1& arguments, Signature sig, Boolean constructor, Boolean wrapExceptions)\r\n at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)\r\n at Umbraco.Cms.Web.BackOffice.Install.InstallApiController.ExecuteStepAsync(InstallSetupStep step, Object instruction)\r\n at Umbraco.Cms.Web.BackOffice.Install.InstallApiController.PostPerformInstall(InstallInstructions installModel)

    Is anyone here familiar with this error?

    Thanks in advance :)

  • Chris Fitz-Avon 3 posts 74 karma points c-trib
    2 days ago
    Chris Fitz-Avon
    0

    I've just worked through the exact same error. In my case the database user that I configured didn't have the permission to create tables and so the install failed.

    After granting the user membership of the db_owner role the install completed successfully.

Please Sign in or register to post replies

Write your reply to:

Draft