Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Darren Hunter 40 posts 110 karma points
    5 days ago
    Darren Hunter
    0

    Media Service not retuning file after upgrading from 7 to Latest version 8.

    I am working on one of our sites that been upgraded from Umbraco version 7 to version 8 and have had a few intresting issues to resolve but the one that manly bugging me at the moment sorry for the pun is the fact that any file in the media folder when loading the file by path from the media service will return null.

    Any new files I add to the media folder and then load through the media service work. I have tried to edit one of the old files and save it again and still find it not loading.

    But as I said if I a new file and then use a path say /media/oidfy987n/somefile.pdf it will load but say I have afile that got a path/media/1033/somefile.jpg and I have verified the files there the media service is not loading the file.

    Even if the files in the media folder in Umbraco.

    I am looking for an easy fix and not having to rebuild the file structure my self or go to the customer and tell them they have to do it.

  • Darren Hunter 40 posts 110 karma points
    4 days ago
    Darren Hunter
    0

    Just to Advise I fixed it using the following code as a template

    https://codeshare.co.uk/blog/how-i-migrated-my-umbraco-v7-site-to-v8-part-1-media/

Please Sign in or register to post replies

Write your reply to:

Draft