Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Martin Rud 255 posts 986 karma points c-trib
    Sep 05, 2023 @ 12:34
    Martin Rud
    0

    SQLite Error 11: 'database disk image is malformed' - not once, but once again

    Umbraco 12 with LOCAL on my Windows 11 and DEV and PROD on Umbraco Cloud.

    It's now the second time I get this error:

    SQLite Error 11: 'database disk image is malformed'
    

    I ran chkdsk /f incl. restarting the system, but still the same error.

    After having contacted Umbraco Support I then renamed my project and then cloned down the DEV environment to have the same name as the original project. I got things up and working again and took the latests doc and data type changes made in LOCAL from the old solutions revisions folder. Then I worked on it again. Nice!

    But then now, about 2 hours later, the error comes up again! 😮😮😢

    I can do the same trick again, but I'd rather find the root cause instead of using time again and again with cloning down project and setting it up again.

    Has anyone tried this and what to do?

    My local project is located in a Google drive-folder.

  • Søren Kottal 706 posts 4503 karma points MVP 6x c-trib
    Sep 05, 2023 @ 12:57
    Søren Kottal
    100

    Google Drive is probably corrupting your sqlite db file.

    I've had that error once, but that was because I was doing YOLO stuff with the database :) I deleted the database files, and let Umbraco re-install, and it worked again.

  • Martin Rud 255 posts 986 karma points c-trib
    Sep 05, 2023 @ 14:10
    Martin Rud
    0

    I think you are right. I have now moved the project out of the Google Drive folder. Then I'll have to setup som backup in another way (apart from Github).

Please Sign in or register to post replies

Write your reply to:

Draft