Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ramya Devendiran 27 posts 148 karma points
    Sep 20, 2023 @ 09:23
    Ramya Devendiran
    0

    Umbraco 12.1.2, ExternalIndex search in backoffice returns NO RESULTS

    I deleted the entire TEMP folder, bin and obj folder. I reran the application (multilanguage) and deleted the write.lock file, then rebuilt external index from backoffice.

    There is no change. The externalindex search returns no results in the backoffice "Examine management".

    When searched for letter "a", it returns few results . one of the results is "fram-a-lokker". When search the entire name "fram-a-lokker", the search returned zero results.Search letter "a" Search "fram-a-lokker" from "a" search result"

  • Huw Reddick 1858 posts 6380 karma points MVP 2x c-trib
    Sep 21, 2023 @ 10:22
  • Huw Reddick 1858 posts 6380 karma points MVP 2x c-trib
    Sep 21, 2023 @ 10:41
    Huw Reddick
    0

    Cause

    Lucene treats differently some special characters which interfere with correct match of the search terms to the respective fields. For example the hyphen ('-') character is a reserved character meaning to exclude keywords, the column (':') character is reserved as a separator between field names and search terms.

    All Lucene special characters: + - && || ! ( ) { } [ ] ^ " ~ * ? : \

    Try passing the search query in quotes "fram-a-lokker" to force it to search for a phrase

  • Ramya Devendiran 27 posts 148 karma points
    Sep 21, 2023 @ 10:48
    Ramya Devendiran
    100

    Thanks Huw Reddick for the reply. The issue is in the umbraco backoffice. I wanted to view how a custom editor property in the index is stored. The search is not working even for the text withtout special characters and search on nodeId enter image description here

  • Ramya Devendiran 27 posts 148 karma points
    Oct 27, 2023 @ 12:49
    Ramya Devendiran
    1

    The issue is fixed. Credits goes to Jesper Mayntzhusen

    Added the below settings to umbraco.cms. "Indexing": { "ExplicitlyIndexEachNestedProperty": false }

    ref: https://github.com/umbraco/Umbraco-CMS/pull/14648 https://docs.umbraco.com/umbraco-cms/reference/configuration/indexingsettings

Please Sign in or register to post replies

Write your reply to:

Draft