Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Hannes Larsson 2 posts 42 karma points
    20 days ago
    Hannes Larsson

    Deploy local Umbraco v12 site to GoDaddy


    I have an Umbraco site that I migrated from v7.4.1 to v12.2.0 (it took a while). I pulled the database from the hosted SQL on Websupport (old Binero) and had to change hosting to be GoDaddy instead as Websupport does not support .NET Core.

    The local site in v12 runs perfectly using the locally hosted MSSQL database used.

    The issue is when I deploy the site and database to the Plesk portal on GoDaddy (via a create and populate data script from the local MSSQL database. From what I can see the MSSQL database hosted at GoDaddy contains the same amount of tables and content (did some tests here and there).

    Issue number 1: When I run the site locally and tries to access the hosted MSSQL site I end up in the "Install Umbraco" page. Almost like the site can access the database, but it does not find the tables within.

    The site I tried different ways from VS2022 to deploy the site via FTP and deploy configs. I ended up using the downloadable "Web Deploy Publishing Settings" in Plesk.

    Issue numer 2: When I access the hosted URL in GoDaddy, I end up in a 500.30 error page. But no logs is created.

    EDIT: Issue number 1 was resolved by letting the locally running webpage create the tables in the hosted database, then the correct schema was set based on the SQL user used in Plesk (as this user only had read/write access to the database). Then I used the uSync package for Umbraco 12 to export complete setup from the local database (running the local Umbraco page pointing to my local database), repoint to the hosted database from local running site, and import the full package. After this the local running website that was pointing to the hosted database was working perfectly.

    Still issue number 2 is there for hosted site, but might think that this is due to incorrect deployment.

  • Huw Reddick 1659 posts 5776 karma points MVP c-trib
    18 days ago
    Huw Reddick

    For issue 2, check that all the folder permissions are correct.

  • Hannes Larsson 2 posts 42 karma points
    18 days ago
    Hannes Larsson

    Just got the answer from GoDaddy that in order to support an Umbraco site on their hosting I need to move from the current subscription (Economy Windows Hosting with Plesk) into a private virtual machine and then set everything up manually.

    I am left GoDaddy and picked BeeByte instead as the creation of an account (only 149SEK/month for 5 sites), and deploying both my MSSQL database and the site took under 15 minutes and worked perfect on first try. Also a much better UX.

    Pretty sure that the answer to issue 2 was the permissions on files that GoDaddy could not give me access right for. Thanks for the tip @Huw!

Please Sign in or register to post replies

Write your reply to: