Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • steschu 88 posts 489 karma points
    Jan 17, 2024 @ 14:15
    steschu
    0

    Whole bunch of errors when upgrading from 12 to 13 with Visual Studio

    Hello,

    I wanted to upgrade umbraco from 12 to 13 as ususal with nuget GUI in visual studio, but encountered many errors:

    First, you cannot upgrade umbraco from 12 to 13 when you do not have the latest upgrade of System.Security.Cryptography.Pkcs, VS simply cancels the Installation of umbraco. 2) You cannot use the latest version of Microsoft.ICU.ICU4C.Runtime (Umbraco does not start)

    So I left Microsoft.ICU.ICU4C.Runtime to the old version 68.2.0.9 and upgraded System.Security.Cryptography.Pkcs to 8.0.0.0

    Then changed to .NET Core 8.0 in the project settings, then upgraded umbraco from 12.1.2 to 13.0.3 with nuget GUI, recompiled and run the project (on the VS built-in IIS Express) ...

    ... and the trouble began. The debugger stopped many times in code files like semphoreslim.cs or list.cs, basically throwing null excpetions or signalisiing that some kind of operation has been cancelled a.s.o. .... after clicking the green arrow multiple times, the maintainance page came up, I did the updgrade, but after that again error: "cannot find complilation library location for package "System.Security.Cryptography.Pkcs".

    I experienced similar difficulties in an older upgrade attempt but could overcome them in not upgrading System.Security.Cryptography.Pkcs to a newer version, but this this does not work.

    P.S.: I work on Windows 10, using the latest version of VS

    Error SemaphhoreSlim

    Error PCKS

  • Yaco Zaragoza 80 posts 334 karma points
    Jan 17, 2024 @ 20:05
    Yaco Zaragoza
    0

    I am having a similar issue

    enter image description here

  • Alexander Tkacuk 19 posts 120 karma points
    Jan 18, 2024 @ 16:50
    Alexander Tkacuk
    100

    Hello

    I did the update in this order and had no problems.

    1 - start "clean solution" in VS.

    2 - Convert the "Umbraco" project to the .NET 8 version

    3 - Build and start "Umbraco". --> No errors should occur here. If any libraries are too old, they should be replaced and the code adapted. So that the next step runs without errors.

    4 Update Umbraco.CMS to Version 13 as a Nuget package.

    5 Build and start Umbraco. --> Everything should now run smoothly.

    Do not update "Microsoft.ICU.ICU3C.Runtime (68.2.0.9)" We dont needed extra "System.Security.Cryptography.Pkcs" in our project

  • David Jazbec 17 posts 127 karma points
    Jan 21, 2024 @ 07:46
    David Jazbec
    0

    Hi there, i had similar issues. I suggest checking the .csproj file. Some entries there may still be referencing the "old" version numbers.

  • Asembli 80 posts 253 karma points
    Jan 27, 2024 @ 23:28
    Asembli
    0

    Hi, just delete this portion from csproj file and uppdate ICU to latest version and everything will work

     <ItemGroup>
    <!-- Opt-in to app-local ICU to ensure consistent globalization APIs across different platforms -->
    <PackageReference Include="Microsoft.ICU.ICU4C.Runtime" Version="68.2.0.9" />
    <RuntimeHostConfigurationOption Include="System.Globalization.AppLocalIcu" Value="68.2.0.9" Condition="$(RuntimeIdentifier.StartsWith('linux')) or $(RuntimeIdentifier.StartsWith('win')) or ('$(RuntimeIdentifier)' == '' and !$([MSBuild]::IsOSPlatform('osx')))" />
    </ItemGroup>
    

    Regards

  • McGern 13 posts 44 karma points
    Mar 12, 2024 @ 11:07
    McGern
    0

    Just followed this advice and it worked for me. No idea why it works, but I am on the latest version now and the solution still works

  • steschu 88 posts 489 karma points
    Feb 02, 2024 @ 19:18
    steschu
    1

    Thank you all for your replys.

    A. Tkacuk gave the right hint - System.Security.Cryptography.Pkcs is not needed. I uninstalled it and then did the upgrade via Nuget as usual - everything worked fine. Do not upgrade Microsoft.ICU.ICU3C.Runtime.

    Stephan

  • Gregor Tušar 7 posts 77 karma points
    Feb 26, 2024 @ 09:03
    Gregor Tušar
    0

    I also had issues with ICU package, so the issue was that I had wrong version set in <RuntimeHostConfigurationOption>. After I synced it with the version of the package (72.1.0.3) the solution run normally.

Please Sign in or register to post replies

Write your reply to:

Draft