Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sorin Botezatu 1 post 71 karma points
    Mar 21, 2024 @ 00:37
    Sorin Botezatu
    0

    System.TimeoutException: Cannot acquire MainDom

    Hi Everyone,

    I see this issue is not new but I was unable to find something that works. Any help is appreciated.

    I am running V13.2.2. with db on SQL Express and its working fine on my development system. When I deployed the site on the server (IIS) using Publish from Visual Studio. I am getting:

    Unhandled exception. System.TimeoutException: Cannot acquire MainDom
       at Umbraco.Cms.Core.Runtime.MainDom.Acquire()
       at Umbraco.Cms.Core.Runtime.MainDom.<>c__DisplayClass12_0.<Acquire>b__0()
       at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)
       at System.Threading.LazyInitializer.EnsureInitialized[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)
       at Umbraco.Cms.Core.Runtime.MainDom.Acquire(IApplicationShutdownRegistry hostingEnvironment)
       at Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.AcquireMainDom()
       at Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.StartAsync(CancellationToken cancellationToken, Boolean isRestarting)
       at Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.StartAsync(CancellationToken cancellationToken)
       at Umbraco.Extensions.WebApplicationExtensions.BootUmbracoAsync(WebApplication app)
       at Program.<Main>$(String[] args) in D:\DEV\MEDAMERICA\MedAmerica\Program.cs:line 12
       at Program.<Main>(String[] args)
    
  • waris 3 posts 73 karma points
    Mar 22, 2024 @ 10:30
    waris
    0

    Hello Sorin, Could you please let me know about the project that you upgrade the project or you had build in version 13 ??

  • Jonas Ragnarsson 1 post 71 karma points
    Mar 22, 2024 @ 18:45
    Jonas Ragnarsson
    0

    I have exactly the same problem running v13.0.3. Working in both my development env and in Azure but deployed to IIS I get this error.

  • J D 2 posts 71 karma points
    26 days ago
    J D
    0

    even i am getting the same error where i have web.config as follows. I am using sql db with umbraco version 13.1.1 and throws the same error i also tries to implement with sqlite db still error was same while deploying in iis server.

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <location path="." inheritInChildApplications="false">
        <system.webServer>
          <handlers>
            <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModuleV2" resourceType="Unspecified" />
          </handlers>
          <aspNetCore processPath="dotnet" arguments=".\sqlDemo.dll" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" hostingModel="inprocess" >
          <environmentVariables>
            <environmentVariable name="ASPNETCORE_ENVIRONMENT" value="Development" />
          </environmentVariables>
          </aspNetCore>
        </system.webServer>
      </location>
    </configuration>
    
  • Ahmet Kaplan 1 post 71 karma points
    26 days ago
    Ahmet Kaplan
    0

    I'm getting a similar error too. I searched all over the internet but couldn't find anything. I am using Umbraco version 13.2.2. Please can you help?

    TimeoutException: Cannot acquire MainDom
    Umbraco.Cms.Core.Runtime.MainDom.Acquire()
    Umbraco.Cms.Core.Runtime.MainDom+<>c__DisplayClass12_0.<Acquire>b__0()
    System.Threading.LazyInitializer.EnsureInitializedCore<T>(ref T target, ref bool initialized, ref object syncLock, Func<T> valueFactory)
    System.Threading.LazyInitializer.EnsureInitialized<T>(ref T target, ref bool initialized, ref object syncLock, Func<T> valueFactory)
    Umbraco.Cms.Core.Runtime.MainDom.Acquire(IApplicationShutdownRegistry hostingEnvironment)
    Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.AcquireMainDom()
    Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.StartAsync(CancellationToken cancellationToken, bool isRestarting)
    Umbraco.Cms.Infrastructure.Runtime.CoreRuntime.StartAsync(CancellationToken cancellationToken)
    Umbraco.Extensions.WebApplicationExtensions.BootUmbracoAsync(WebApplication app)
    Program.<Main>$(string[] args) in Program.cs
    Program.<Main>(string[] args)
    
  • Niklas Fanhgol 2 posts 72 karma points
    17 days ago
    Niklas Fanhgol
    0

    I am running the exact same settup en getting the same error umbraco: 13.1.1 Db: SQLSERVEREXPRESS IIS: 10.0.19041.1

    The site runs fine from Visual studio but when i publish to my win11 server this error popps up. I thought it might be an connection string issue butt no changes to the connection string affects the error in any way so i think it triggers before reaching out to the DB My publish settings are as follows enter image description here

  • Niklas Fanhgol 2 posts 72 karma points
    17 days ago
    Niklas Fanhgol
    1

    I figured out the issue. The IIS_IUSRS user is missing permissions folder where the files are located.

    Refference: https://docs.umbraco.com/umbraco-cms/fundamentals/setup/server-setup/permissions I gave mine all permissions and it solved the issue enter image description here

Please Sign in or register to post replies

Write your reply to:

Draft