Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Priya 5 posts 74 karma points
    17 days ago
    Priya
    0

    SettingUp umbraco on IIS with http port

    Hi All ,

    I am using umbraco 13 in aspnet core application , I hosted my project in stage server on IIS where i have assigned IP with http port and with loadbalancer it has to redirect to https , I get an error: Boot failed - Failed to determine the https port for redirect. Can we setup umbraco with Http and how can i fix this

  • Yakov Lebski 567 posts 2153 karma points
    15 days ago
  • Priya 5 posts 74 karma points
    1 week ago
    Priya
    0

    Thank you for the response. I removed production mode for http IP to work. But later when I got https URL , I created production appsettings json file and added settings provided from the website , now i get too many redirects error when i browse url

  • Yakov Lebski 567 posts 2153 karma points
    1 week ago
    Yakov Lebski
    0

    Just keep in mind that redirects are cached by browser - it is good idea to check in single incogntio mode in chrome.

    did you change enviroment varaiable for swith to production mode?

  • Priya 5 posts 74 karma points
    1 week ago
    Priya
    0

    is it this one

    { "Umbraco": { "CMS": { "Runtime": { "Mode": "Production" }, "Global": { "UseHttps": true }, "ModelsBuilder": { "ModelsMode": "Nothing" }, "WebRouting": { "UmbracoApplicationUrl": "https://stageexample>/" } } } }

    I created new appsettings.json file and added this , with http://10.10.10.10 IP when i browse to /umbraco ..it changes to https and with url i get too many redirects

  • Priya 5 posts 74 karma points
    5 days ago
    Priya
    0

    It worked by removing Mode:Production and Https , as we are using loadbalancer to redirect to https url , ip's and url works fine individually

Please Sign in or register to post replies

Write your reply to:

Draft