Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • webdev 5 posts 76 karma points
    Apr 06, 2016 @ 07:37
    webdev
    0

    Icons missing from TinyMCE v3

    Morning, just downloaded Umbraco v7.3.4 several days ago and am learning as I go.

    I have noticed that within the rich text editor, the tinyMCE menu only shows 7 icons to the most basic formatting functions. Even when I edit the datatype and include additional icons and functionality - nothing happens. enter image description here

  • Dennis Adolfi 1075 posts 6436 karma points MVP 4x c-trib
    Apr 06, 2016 @ 08:35
    Dennis Adolfi
    0

    Hi webdev!

    I see you are using the Grid. The functions (icons) avalible in the grid is configured for each specific gridlayout on the DocumentType, and not on the base datatype "Richtext Editor".

    To enable more functions (icons) for your TinyMCE, edit the property for your datatype grid to enable more functions (Se image).

    enter image description here

  • webdev 5 posts 76 karma points
    Apr 06, 2016 @ 13:59
    webdev
    0

    Thanks Dennis, really appreciated

    Thought I'd maybe got a dodgy download :-)

    Will have a go now

  • Dennis Adolfi 1075 posts 6436 karma points MVP 4x c-trib
    Apr 06, 2016 @ 14:01
    Dennis Adolfi
    0

    Hehe. :)

    Have a got at it and let me know if it worked out for you.

  • webdev 5 posts 76 karma points
    Apr 06, 2016 @ 14:12
    webdev
    0

    Hi again

    Ok I don't think my functionality is the same as your example.

    When selecting a content page and making a new editable area eg(Article Wide), then selecting the cog icon to the right, I am presented with settings to change the background colour and style background image.

    That's all.

    Within the Article Wide if I select Rich text editor and the the cog icon I get a blank slide out modal effect from the right of the screen.

    Thanks

  • Dennis Adolfi 1075 posts 6436 karma points MVP 4x c-trib
    Apr 07, 2016 @ 07:34
    Dennis Adolfi
    0

    It sounds like you are clicking on the cog in the Content area? Go to the documentype i Settings and select the cog for the grid. See my last gif.

  • webdev 5 posts 76 karma points
    Apr 07, 2016 @ 07:56
    webdev
    0

    Hi Dennis,

    No I also tried going into settings/document type too.

    I select landing page or text page and they both have no grid. I've included a screen dump.

    enter image description here

    Thanks

  • Dennis Adolfi 1075 posts 6436 karma points MVP 4x c-trib
    Apr 07, 2016 @ 08:54
    Dennis Adolfi
    0

    Oh, I just noticed that you have Umbraco 7.3.4, sorry. And i see on your screendump that you are using Fanoe starterkit right?

    Then to enable more functions for the grid RTE go to Developer > DataTypes > Grid TextPage and there you can set the functions you´d like.

    Then do the same for datatypes Grid FrontPage and Grid BlogPost

  • webdev 5 posts 76 karma points
    Apr 07, 2016 @ 10:03
    webdev
    1

    Thanks again Dennis

    Much appreciated

  • Dennis Adolfi 1075 posts 6436 karma points MVP 4x c-trib
    Apr 07, 2016 @ 10:08
    Dennis Adolfi
    0

    No problem webdev! :) Happy to help!

    Have a great day!

    Did it work for you? If so, remember to Mark as soultion to close this thread and so other may find this solution quicker..

  • Gordon 15 posts 96 karma points
    Mar 02, 2017 @ 12:03
    Gordon
    0

    I've recently posted this which might be related. I've had no luck. Any other thoughts Dennis?

    Is it possible to upgrade just TinyMCE in an Umbraco installation, rather than upgrading all of Umbraco maybe...?

    Thanks

Please Sign in or register to post replies

Write your reply to:

Draft