Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • René 327 posts 852 karma points
    May 08, 2016 @ 21:49
    René
    0

    Umbraco 7.4 _shutDownMessage=CONFIG change HostingEnvironment initiated shutdown

    Hi

    I have a problem getting Umbraco debug in visualstudio to work.

    Umbraco version 7.4.3 assembly: 1.0.5948.18141

    Microsoft SQL Server Express (64-bit)

    Windows 10 pro 64 bit

    I have upgraded to 743 from 730. But the problem was there before upgrading.

    If i run the page from local iis eg: mysite.local it is working

    When i run the page from http://localhost:55941/ visual Studio i only get a totally blank page.

    I have a copy of the website on unoeuro and the problem is also there.

    The umbraco backoffice is also blank.

    enter image description here

    I have this error in the console:

    enter image description here

    I have tried recycle app pool, rebuild, different browsers chrome edge .. Nothing works.

    I can see there are different solutions in this forum but noting works.

    Is there any one wo can point me in the right direction :-) René

  • Paul Wright (suedeapple) 264 posts 666 karma points
    May 08, 2016 @ 22:34
    Paul Wright (suedeapple)
    0

    Anything in the app_data logs?

    Sounds like a permissions problem. Try adding network service to your project files

  • René 327 posts 852 karma points
    May 09, 2016 @ 05:37
    René
    0

    Hi

    Forgot to show. This is from the log:

    HostingEnvironment initiated shutdown
    

    CONFIG change CONFIG change CONFIG change CONFIG change CONFIG change Change in AppOffline.htm Change in AppOffline.htm Change in App_Offline.htm Change in GLOBAL.ASAX HostingEnvironment forårsagede nedlukning

    shutDownStack= ved System.Environment.GetStackTrace(Exception e, Boolean needFileInfo) ved System.Environment.getStackTrace() ved System.Web.Hosting.HostingEnvironment.InitiateShutdownInternal() ved System.Web.Hosting.HostingEnvironment.InitiateShutdownWithoutDemand() ved System.Web.HttpRuntime.ShutdownAppDomain(String stackTrace) ved System.Web.Configuration.HttpConfigurationSystem.OnConfigurationChanged(Object sender, InternalConfigEventArgs e) ved System.Configuration.Internal.InternalConfigRoot.OnConfigChanged(InternalConfigEventArgs e) ved System.Configuration.BaseConfigurationRecord.OnStreamChanged(String streamname) ved System.Web.DirectoryMonitor.FireNotifications() ved System.Web.Util.WorkItem.CallCallbackWithAssert(WorkItemCallback callback) ved System.Web.Util.WorkItem.OnQueueUserWorkItemCompletion(Object state) ved System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx) ved System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx) ved System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() ved System.Threading.ThreadPoolWorkQueue.Dispatch()

  • Nicholas Westby 2033 posts 7006 karma points c-trib
    May 09, 2016 @ 21:21
    Nicholas Westby
    0

    Based on that stack trace, I'd make sure you do not have an app_offline.htm file at the root of your site: https://weblogs.asp.net/scottgu/App5F00Offline.htm-and-working-around-the-2200IE-Friendly-Errors2200-feature

    Also, if you open the network tab in Chrome, you can view the response page from the 500 error. That can give you specific details about what caused the 500 error.

    If you get the generic 500 error page, you can enable viewing the error details by changing your web.config so that customErrors="Off": https://msdn.microsoft.com/en-us/library/h0hfz6fc(v=vs.71).aspx

  • René 327 posts 852 karma points
    May 10, 2016 @ 06:26
    René
    0

    Hi

    Tanks for your reply and time to answer.

    I´m lost on this one. Any pointers in any direction to solve it would be great.

    Here is the info from the network tab

    Request URL:http://localhost:55941/
    Request Method:GET
    Status Code:500 Internal Server Error
    Remote Address:[::1]:55941
    
    
    Response Headers
    view source
    Content-Length:0
    Date:Tue, 10 May 2016 06:19:08 GMT
    Server:Microsoft-IIS/10.0
    X-SourceFiles:=?UTF-8?B?SDpcU291cmNlIENvbnRyb2xcYmlnZ3JleVVtYnJhY29cd2Vic2l0ZVx3ZWJzaXRl?=
    
    Request Headers
    view source
    Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    Accept-Encoding:gzip, deflate, sdch
    Accept-Language:en-US,en;q=0.8,da;q=0.6
    Cache-Control:max-age=0
    Connection:keep-alive
    Host:localhost:55941
    Upgrade-Insecure-Requests:1
    User-Agent:Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36
    

    Thee is no app_offline.htm in the root

    Costum errors are set <customErrors mode="Off" />

  • René 327 posts 852 karma points
    May 10, 2016 @ 06:29
    René
    0

    Hi

    Here is info from the log file

     2016-05-10 07:37:22,470 [P5140/D13/T199] INFO  Umbraco.Core.UmbracoApplicationBase - Application shutdown. Details: HostingEnvironment
    
    _shutDownMessage=HostingEnvironment initiated shutdown
    HostingEnvironment forårsagede nedlukning
    
    _shutDownStack=   ved System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
       ved System.Environment.get_StackTrace()
       ved System.Web.Hosting.HostingEnvironment.InitiateShutdownInternal()
       ved System.Web.Hosting.HostingEnvironment.InitiateShutdownWithoutDemand()
       ved System.Web.Hosting.PipelineRuntime.StopProcessing()
    
  • René 327 posts 852 karma points
    May 10, 2016 @ 09:02
    René
    0

    Hi again

    I have been trying to compare the error logs from the 2 different ways to run the app.

    1. where i start up http://localhost:55941/ (Not working)

    2. where i start up domainname.local (Working)

    enter image description here

    The difference besides the date time

    http://localhost:55941/

    1. 2016-05-10 09:29:39,931 [P16860/D3/T63] INFO Umbraco.Core.UmbracoApplicationBase - Application shutdown. Details: BinDirChangeOrDirectoryRename

    domainname.local

    1. 2016-05-10 09:29:49,959 [P16860/D4/T68] INFO Umbraco.Core.Sync.ApplicationUrlHelper - ApplicationUrl: http://domainname.local:80/umbraco (UmbracoModule request)

    René

  • Nicholas Westby 2033 posts 7006 karma points c-trib
    May 11, 2016 @ 02:07
    Nicholas Westby
    0

    I have seen something like this before when I didn't have something installed that was required by the web.config. For example, I always install Application Request Routing (ARR), as that includes some bits necessary for redirects to work (otherwise, you may get a 500 error).

    Maybe also try clearing your cookies (and other browser files). I have seen funky issues with upgrades that have dropped cookies that made Umbraco act weird.

    Would also be worth creating an event in the Global.asax to see if requests are even being processed before they throw an error.

    Try also putting a static HTML file in the root of the site to see if that gets returned when you view it from Visual Studio. Might offer up additional clues.

    One final thing to try would be to ensure you don't have too many redirects in your web.config. If the web.config is too large, you'll get an error.

  • René 327 posts 852 karma points
    May 17, 2016 @ 08:20
    René
    0

    Hi

    If anyone comes by, i did not find the solution.

    I did a new install and moved the content for the web app, to get it up running again.

    René

Please Sign in or register to post replies

Write your reply to:

Draft