Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Mike Rowe 9 posts 109 karma points
    Jun 25, 2016 @ 02:18
    Mike Rowe

    Role Based Public Access dialog fails to open

    Steps to recreate

    1 - Log into backend as administrator

    2 - Choose a content node, right click, choose "Role based protection"

    3 - Pick a role who will have access to this page

    4 - In the "Login Page" or "Error Page" click "Choose"

    PROBLEM: The dialog to pick the login and error pages doesn't appear. Delete also does nothing. However the "Remove protection" button does work.

    Troubleshooting and other comments:

    • Upgraded from 7.40 ->7.43

    • Deleted /App_Data/umbraco.config and restarted web site

    • Republished whole site
    • Attempted to confirm my admin "User Permissions" but "Select pages to modify their permissions" list is blank.
    • Tried all of the above as different administrator and saw same behavior.
    • Database on host is Mircosoft SQL Server 2014. This is the staging environment. I frequently backup my live site (Mircosoft SQL Server 2012) to the staging site.
    • If a member has the requirements, he is assigned to the role that has access to this content:

      var result = ApplicationContext.Current.Services.MemberService.FindMembersInRole("Member Access Group", member.Username).Any();
      • Confirmed with hosting environment full permissions for all folders "IUSR", "IIS_IUSRS", "NETWORK SERVICE"

    Anything that can be suggested would be greatly appreciated.

    Thank You

  • Mike Rowe 9 posts 109 karma points
    Jun 27, 2016 @ 12:38
    Mike Rowe

    SOLVED... This problem manifested itself in other ways also. I could not update a template. Could not see the properties tab of a template. Also, Users/User Permissions the content picker did not render.

    The solution was to copy (ftp) the bin, umbraco and umbraco_client folders to overwrite the existing folders. All works very well now.

Please Sign in or register to post replies

Write your reply to: