Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ivan 2 posts 72 karma points
    Jul 07, 2016 @ 20:05
    Ivan
    0

    Document Type not Available in Compositions

    Hi all.

    Maybe a stupid question, but I have a couple of document types. I want to add SEO Fields to this document types. I created a document type without a template called "SEO Fields" i have seo tab there with a 2 fields. When I try to make an document type based on "SEO Fields" the "SEO Fields" checkbox in composition dialog is not enabled. Why is that? What makes some document types available and another not?

    enter image description here

  • Sebastiaan Janssen 5044 posts 15453 karma points MVP admin hq
    Jul 08, 2016 @ 13:30
    Sebastiaan Janssen
    105

    There can be 2 reasons for this:

    1. A property with the same alias exists on both document types. We can't know which property to choose, so we can not compose the two document types
    2. The document type Sector is already being composed in another document type. In order to prevent circular compositions, we don't allow this
  • Al Nicholl 15 posts 97 karma points
    Jul 25, 2018 @ 09:10
    Al Nicholl
    0

    Thank you for this, Sebastiaan! I didn't realise you needed to have properties with different aliases. Totally makes sense.

    I'd also forgotten that if you create a composition with the same tab name as another doctype, the properties get merged with that tab. This has been the main reason I've not used compositions much in my work so it's opened up lots of possibilities!

    Thanks again. H5YR!

    Al

  • Ivan 2 posts 72 karma points
    Jul 08, 2016 @ 19:50
    Ivan
    0

    Thanks a lot!

    It was first reason. Later I saw it in the documentation.

  • Samira 113 posts 452 karma points
    Jul 11, 2016 @ 13:23
    Samira
    0

    Hi Lvan,

    you can try this.

    1) First create a folder inside The Document type and name it to Compositions.

    2) Then Inside Compositions folder create a document type SEO. and add some fields into it. and then click save.

    3) Then go to your document type and click on compositions there you can see the your SEO checkbox is enable.

    enter image description here

Please Sign in or register to post replies

Write your reply to:

Draft