Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dominic Tse 21 posts 110 karma points
    Sep 06, 2016 @ 05:01
    Dominic Tse
    0

    Umbraco Backoffice - Forgotten password does not work - A from address must be specified.

    Hi,

    I have recently upgraded my web site from Umbraco 7.4.3 to 7.5.2. I've got "A from address must be specified" when I tried to test the Forgotten password feature in the Umbraco Backoffice login page.

    I have already specified the SMTP address and From email address already in Web.config and umbracoSettings.config respectively.

    Can anyone please give me some idea how to fix this?


    Web.config under mailSettings

      <smtp>
        <network host="my_email_service" userName="" password="" />
      </smtp>
    

    umbracoSettings.config

    <notifications>
      <email>[email protected]</email>
    </notifications>
    

    at System.Net.Mail.SmtpClient.SendAsync(MailMessage message, Object userToken) at System.Net.Mail.SmtpClient.SendMailAsync(MailMessage message) at Umbraco.Core.Security.EmailService.

  • Dennis Adolfi 1075 posts 6435 karma points MVP 4x c-trib
    Sep 06, 2016 @ 06:18
    Dennis Adolfi
    102

    Hi Dominic.

    You are missing the from field for the smtp segment.

    Try adding the following:

    <smtp from="[email protected]">
        <network host="my_email_service" userName="" password="" />
      </smtp>
    
  • Dominic Tse 21 posts 110 karma points
    Sep 06, 2016 @ 06:30
    Dominic Tse
    1

    Thanks Dennis. It works!

  • Dennis Adolfi 1075 posts 6435 karma points MVP 4x c-trib
    Sep 06, 2016 @ 06:41
    Dennis Adolfi
    0

    Awesome Dominic!

    Thanks for confirming that it works!

    Have a great day!

  • Sebastiaan Janssen 5009 posts 15264 karma points MVP admin hq
    Sep 06, 2016 @ 07:57
    Sebastiaan Janssen
    1

    Pro tip: one of the Configuration health checks would have told you about this error as well and will allow you to update that configuration right from Umbraco:

    enter image description here

  • Nik 1522 posts 6732 karma points MVP 5x c-trib
    Sep 06, 2016 @ 08:11
    Nik
    1

    This looks like it should be part of a 7.5 Pro Tips blog post ;-)

  • Vidar Solberg 6 posts 124 karma points
    Oct 26, 2016 @ 14:08
    Vidar Solberg
    0

    Thanks for the tip, Sebastian. :-) But it seems like the health check fix only changes the default email address in umbracoSettings.config:

    <notifications>
      <email>[email protected]</email>
    </notifications>
    

    Without doing anything with the <smtp> in web.config. So it's not fixing the real problem. Adding the from field manually is the real fix. (Thanks Dennis!)

  • Sebastiaan Janssen 5009 posts 15264 karma points MVP admin hq
    Oct 26, 2016 @ 14:41
    Sebastiaan Janssen
    0

    @Vidar yes, of course we cannot fix your SMTP settings this easily, it requires multiple configuration options. But if you had set up your SMTP settings correctly in web.config it would still send from the wrong email address, that's what this health check is for. I'll see if I can update the text to make this more clear.

  • Sebastiaan Janssen 5009 posts 15264 karma points MVP admin hq
    Oct 26, 2016 @ 14:42
    Sebastiaan Janssen
    1

    Ah.. and with that said.. I see my earlier reply was a bit too optimistic, it doesn't fix the problem I thought it fixed, well spotted!

  • Dominic Tse 21 posts 110 karma points
    Sep 06, 2016 @ 23:42
    Dominic Tse
    0

    Thanks for the tip.

  • Chris Clancy 56 posts 123 karma points
    Dec 08, 2016 @ 15:55
    Chris Clancy
    0

    I can't seem to get the 'Forgotten password' feature to work.

    My Web.config looks like this:

    <mailSettings>
      <smtp from="[email protected]">
        <network host="smtp.gmail.com" userName="[email protected]" password="myEmailPassword" />
      </smtp>
    </mailSettings>
    

    My umbracoSettings.confiog looks like this:

    <notifications>
      <!-- the email that should be used as from mail when umbraco sends a notification -->
      <email>[email protected]</email>
    </notifications>
    

    If I go to Forgotten Password and Submit....nothing happens. Sometimes there will be a failure message on the form but I get nothing in the logs.

    I'm working locally and connecting to a DB on Azure (* I don't expect that to make any difference *)

    Do I need to do anything else here?

    Thanks

    Chris

Please Sign in or register to post replies

Write your reply to:

Draft