Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Tom 34 posts 154 karma points
    Sep 08, 2016 @ 08:51

    Change user permissions to allow save gives error

    I'm trying to update user permissions on the content tree to allow user to copy nodes. Unfortunately I ran into the following error while reviewing the Console in web dev tools;

    Sys.Net.WebServiceFailedException: The server method 
    'SaveNodePermissions' failed with the following error:  
    System.Data.SqlClient.SqlException-- Violation of PRIMARY KEY constraint 
    'PK_umbracoUser2NodePermission'. Cannot insert duplicate key in object 
    'dbo.umbracoUser2NodePermission'. The duplicate key value is (18, 1048,O).
    The statement has been terminated.

    Cleared rows for specific user id and tried saving it again but didn't quite work.. Does anyone got any clues about what's happening here?

Please Sign in or register to post replies

Write your reply to: