Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Brett Spencer 88 posts 259 karma points
    Sep 14, 2016 @ 17:52
    Brett Spencer
    0

    Journey to upgrade Umbraco from 7.2.8 to Latest

    Right now the latest is 7.5.3. Maybe by the time I'm done, there will be another release.

    I am documenting this process because it has been incredibly hard to upgrade. I will share my hardships and hopefully come across the way to fix so that all may benefit.

    7.2.8 to 7.4.x did not work. All my Doc Types are throwing errors.

    Restarting from scratch with 7.3...

    7.2.8 to 7.3.0 Did a nuget install. Had quite a few problems with assembly references even with using WinMerge and making sure all was correct.

    I had to reinstall nuget packages to fix. Found here: http://umbraco.com/follow-us/blog-archive/2015/7/29/upgrading-your-umbraco-site-to-mvc5-and-webapi2/

    During Database upgrade, I had a duplicate row insert error. Looked in the log for the row id and changed the name of the alias.

    Worked. But now I can not see any of my Partial views and Macro partial views in the back-end. I'm not the only one with this issue. See: https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/74333-null-reference-error-when-trying-to-view-doctypes. EDIT: Templates are also throwing Null reference error. When clicking on a media type that is a descendant of another - the tree resets and doesn't stay on the selected media type.

    Seems to be no resolution. Maybe the next upgrade will work.

    Time spent so far: 2 workdays.

    Trying to do step upgrades of minor releases but nuget won't allow it.

    PM> update-package UmbracoCms -version 7.3.1 Update-Package : 'UmbracoCms' was not installed in any project. Update failed. At line:1 char:15 + update-package <<<< UmbracoCms -version 7.3.1 + CategoryInfo : NotSpecified: (:) [Update-Package], PackageNotInstalledException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand

    I tried to skip to the 7.4.0 release thinking it was a nuget package issue but I recieved the same error. So something is wrong with nuget upgrade.

    I'm starting to believe that manual upgrades might be better. I will have to roll everything back and start from scratch again!

  • Dennis Aaen 4492 posts 18178 karma points admin hq c-trib
    Sep 19, 2016 @ 14:26
    Dennis Aaen
    1

    Hi Brett,

    Sorry to hear that you have spend two days on upgrading. Perhaps this topic can help you further to get your Umbraco installation running NuGet.

    Try to see Sebastiaan´s comment.

    https://our.umbraco.org/forum/getting-started/installing-umbraco/74654-from-manual-to-nuget-upgrade

    Hope this helps,

    /Dennis

  • Brett Spencer 88 posts 259 karma points
    Sep 20, 2016 @ 20:02
    Brett Spencer
    100

    hi five Dennis!

    Not sure why it didn't occur to me to try this in the first place... but that is the beauty of having a community.

    I followed what Sebastiaan suggested here:

    https://our.umbraco.org/forum/getting-started/installing-umbraco/74654-from-manual-to-nuget-upgrade#comment-256084

    Did a quick tour / test and seems that took care of every problem I have had over the year long attempt to upgrade. I had no errors this time... everything is visible. Awesome. And it only took me about an hour.

    I will continue to expand our sites now and report back if I find an issue. Otherwise... THIS WORKS.

  • Tony 105 posts 163 karma points
    Jan 13, 2022 @ 12:22
Please Sign in or register to post replies

Write your reply to:

Draft