Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jesper Hauge 298 posts 486 karma points c-trib
    Sep 22, 2016 @ 07:37
    Jesper Hauge
    0

    Corrupt cache won't repair

    Currently looking at a site we upgraded from v7.2.8 to v 7.5.3 running as an Azure App, that over night started showing an YSOD on the frontpage stating that the xml cache was corrupt, and to use the health check to repair.

    Repair runs, but when done health check still states that the xml cache is corrupt, and YSOD on frontpage was still there.

    I then tried restarting the Azure App, which made the YSOD go away, but the health check still insists that the xml cache is corrupt. It also states that the number of invalid xml structures is 0.

    I tried setting logging level to debug, and running the check, and the fix. Same result, but nothing in the log indicates any problems during check and fix.

    Any ideas appreciated.


    Ok so I fixed the problem (sort of), advice from Sebastiaan Jansen was to republish site, as in really publish, not "Republish site". So I tried republishing everything, no luck, then emptying deleted items bin, then some more publishing, noticing a message in the stating "Content 'blah blah' with Id '10435' will not be published because it's parent's publishing action failed or was cancelled. After this message, and searching for the node, and republishing this node, the corrupt xml cache problem, went away.

    Regards Jesper Hauge

Please Sign in or register to post replies

Write your reply to:

Draft