Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Jonas 119 posts 202 karma points
    Oct 19, 2016 @ 08:49

    Error upgrading from 7.3.8 to 7.5.3

    This works fine locally, but when moving code to production environment I get this error. All references looks ok.

    \umbraco\Views\AuthorizeUpgrade.cshtml(67): error CS1061: 'System.Web.Mvc.HtmlHelper

  • Alex Skrypnyk 4637 posts 16596 karma points MVP 2x admin
    Oct 19, 2016 @ 09:13
    Alex Skrypnyk

    Hi Jonas,

    Did you change this file?

    In our version of Umbraco there are no extension method AngularExternalLoginInfoValuesScript.



  • Yakov Lebski 155 posts 682 karma points
    Oct 19, 2016 @ 17:54
    Yakov Lebski

    Simple solution is copy umbraco and umbraco_client from packages files

  • Stuart Aldridge 1 post 71 karma points
    Oct 20, 2016 @ 15:51
    Stuart Aldridge

    I have also encountered this error today whilst upgrading from 7.3.3 to 7.5.3 using Nuget, however I can't even run the project locally.

    The file AuthorizeUpgrade.cshtml has not been edited manually but I can see from version control that there have been quite a few changes made to this file - included the introduction of the below.

    <script type="text/javascript">
            document.angularReady = function (app) {     @Html.AngularExternalLoginInfoValuesScript((IEnumerable<string>)ViewBag.ExternalSignInError)

    Any help would be appreciated on this.

    Thanks, Stuart

  • Euge 23 posts 130 karma points
    Jun 08, 2017 @ 11:58

    I've just made a copy of the Umbraco database for a site pointed the site to the copy and I'm getting the same error as above. This only happens when I go to the back office. I'm using 7.5.3

  • Sebastiaan Janssen 4616 posts 12867 karma points MVP admin hq
    Oct 20, 2016 @ 16:18
  • Jesse Andrews 41 posts 136 karma points
    Feb 21, 2018 @ 01:07
    Jesse Andrews

    I'm running into this issue as well after upgrading from 7.4.3 to 7.5.14 with nuget. It works fine in my local environment, but it fails once it's deployed to azure. I've confirmed that the solution in the other thread isn't the answer, as none of my references point anywhere they shouldn't be.

    I also tried manually copying over the dlls, but sadly that didn't help. The problem isn't the dll itself, as I confirmed that the extension is inside umbraco.dll.

    Lastly, I tried bypassing the issue by running the upgrade in my local environment, which upgraded the database without issue. This script is used throughout umbraco though, so that didn't avoid the problem.

  • John Ligtenberg 53 posts 212 karma points
    May 15, 2018 @ 15:39
    John Ligtenberg

    I've also run into this issue when deploying a site to Azure after an Umbraco upgrade from 7.3.5 to 7.10.4

    The site was working fine locally.

    By copying the umbraco and umbraco_client folders into the site manually, from my local site to Azure, I was able to do the database upgrade. After a subsequent TeamCity deployment the problem returned. It looks like I may have to add the umbraco and umbraco_client folders to GIT.

    I hope someone has a better solution. Is this a bug?

Please Sign in or register to post replies

Write your reply to: