Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Lord 55 posts 208 karma points
    Oct 21, 2016 @ 09:36
    Chris Lord
    1

    S3 Provider - Umbraco 7.5.3

    I am using this S3 provider on a site (https://github.com/ElijahGlover/Umbraco-S3-Provider) which I recently upgraded to Umbraco 7.5.3.

    Since the upgrade, media requests for NON image files are throwing a 404. I have setup fiddler and can see image requests being served from the S3 bucket, but requests for PDFs, DOCs etc are not attempting to get from S3. If I manually place the files in the physical media directory, then it works ok, so IIS must be throwing the 404.

    As far as I can tell I have configured everything as per the documentation, I have tried re-installing the package, as well as the image processer web config package, but no joy.

    Anyone experienced anything similar, I am pulling my hair out and don't know if it's the package is incompatible with 7.5.3, or something in the config has been overwritten during the upgrade (i've compared with backup and nothing obvious)

    I am at the point where I am considering ditching the package and having the media physically on the web server, which I really want to avoid if possible!!

  • Andrew Dobb 4 posts 75 karma points
    Nov 30, 2016 @ 11:54
    Andrew Dobb
    0

    I'm getting this issue as well, as far as I can tell the images themselves are throwing a 404 when navigating to them directly. However if you navigate to them through the Image Processor then they render correctly. Thanks, Andy

  • Chris Lord 55 posts 208 karma points
    Nov 30, 2016 @ 13:19
    Chris Lord
    102

    My issue was the upgrade overwriting the global.asax, so the FileSystemVirtualPathProvider wasn't being configured.

    If you right click on the global.asax and choose "View Markup", make sure it inherits from your application and not the default Umbraco

  • Andrew Dobb 4 posts 75 karma points
    Nov 30, 2016 @ 14:13
    Andrew Dobb
    1

    Perfect, I've had to migrate from the Hybrid Version so overwrote the global file, forgetting to update the inheritance. Thanks, Andy

  • David McDonnell 53 posts 251 karma points
    May 10, 2018 @ 12:25
    David McDonnell
    0

    Hi Andy (Dobby!) :)

    Long time no see, I am working on the same thing now and have a similar issue, I have my media uploading to S3 but my images are not loading on the site or CMS, any ideas?

    CMS version 7.7.7 I have installed all the packages and configured as per guidelines on the Github site.

  • Andrew Dobb 4 posts 75 karma points
    May 13, 2018 @ 14:41
    Andrew Dobb
    0

    Hi,

    We solved this outside of Our, but for those who are having issues...

    • We double checked all of the settings and code (all ok) We then used fiddler (and Wireshark) to investigate the traffic to and from the application This led us to a permissions issue in AWS Fixing the permissions solved the problem.

    Hope that helps everyone else, Andy

  • AK 2 posts 72 karma points notactivated
    Jul 26, 2019 @ 13:47
    AK
    0

    Hi Andy,

    It's been a while since there has been any activity on this item, but I'm having this issue.

    All configurations seem to be correct but I'm unable to pull non image assets from S3.

    Curious what the config changes are for AWS. I've already got the bucket policy set to public read. So I'm not sure what else it might be.

  • Andrew Dobb 4 posts 75 karma points
    Jul 26, 2019 @ 14:17
    Andrew Dobb
    0

    Hi AK,

    I can't remember off by heart and I no longer work at the same place so can't take a look. However I do remember Umbraco requiring write access to upload items to the media library. I believe we set up private admin access for the site, but don't quote me on that!

    Hope that helps and have a good weekend,

    Andy

  • MarvinZ 4 posts 24 karma points
    May 07, 2020 @ 21:03
    MarvinZ
    0

    Hi guys, Im a few months late into the conversation... I would like to know if somebody has been able to make this work without the need of setting the bucket policy to public read?

Please Sign in or register to post replies

Write your reply to:

Draft