Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Nicolás Cova 48 posts 120 karma points
    Nov 07, 2016 @ 15:37
    Nicolás Cova

    Backend can't retrieve Members from Database

    Hello everybody,

    I'm in a bit of a tight spot right now and I'd like to see if you guys can figure this out.

    Here's what's going on: I am currently working on site built in Umbraco Cloud (version 7.5.4). My client asked me for some changes on the site and I thought it would be better if I implemented those changes on a local installation rather than doing so on the Umbraco Cloud site. So I downloaded a copy of the database, made a new Umbraco 7.5.4 site in IIS and logged into the backend. Everything looked OK (content, doctypes, templates, etc.), but I noticed that I had no members. The Member Types and Member Groups were OK, I just didn't have any members.

    After that, I took a peek at the dbo.cmsMember table and found out that my members are there. Next, I decided to recycle my application pools, start & stop my IIS, and log back in and I still had no members. Finally, I opened the developer tools in my browser and reloaded the backend and I found out the following error every time I tried to view my members:

    members section error in 7.5.4

    This error seemed kind of odd to me. I thought the .zip file I downloaded was corrupt or something. So I deleted the site, deleted the database, setup everything again, and ran into the same error. I was kind of baffled by this result (since I can see still see my members in the Umbraco Cloud site). Later, I decided to try with previous versions of Umbraco to see if maybe there was something wrong with the 7.5.4 .zip file. I tried every version between 7.5.4 and 7.5.0, and with every version I got the same error.

    Finally, I gave it one last shot with version 4.5.3 and I got a different error message:

    members section error on 4.5.3

    In case you're wondering, the response I get from those error messages is the following:

    SyntaxERROR: JSON.parse: unexpected character at line 1 column 1 of JSON data.

    Anyways, has this ever happened to you guys before? Is it OK to export a database from an Umbraco Cloud installation to use it in a regular local Umbraco installation? Or am I doing somehting wrong here?

    Thanks in advance.

Please Sign in or register to post replies

Write your reply to: