Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Simone Chiaretta 134 posts 541 karma points c-trib
    Dec 16, 2016 @ 08:52
    Simone Chiaretta

    Error installing packages on 7.5.6

    Hi, I'm trying to install a package with the latest umbraco 7.5.6

    After I click install I get the error:

    System.IO.DirectoryNotFoundException: Could not find a part of the path 

    I've been trying to debug the problem and I noticed the following that after uploading the file I have e8ecce7e-cfbb-4d54-9ff9-fab17c8a9a42.umb file in the App_Data folder, and also a folder e8ecce7e-cfbb-4d54-9ff9-fab17c8a9a42 with the above file unzipped.

    But as soon as I click "Install" the temp folder gets deleted and only the .umb remains. Thus the package installer doesn't find the contents of the package.

    Is this a bug introduced with 7.5.6 or some weird problem on my machine?

  • Thomas Heaney 8 posts 29 karma points
    Dec 17, 2016 @ 12:32
    Thomas Heaney

    Simone, I've had the same problem but I don't think it's a bug. I tried installing plugins on earlier versions of Umbraco and get the same error. My guess is that it's a permissions problem.

  • Simone Chiaretta 134 posts 541 karma points c-trib
    Dec 17, 2016 @ 14:59
    Simone Chiaretta

    Can't be a permission problem... looks like the folder is there but is deleted before the import happens

  • Simone Chiaretta 134 posts 541 karma points c-trib
    Dec 17, 2016 @ 15:58
    Simone Chiaretta

    I managed to install.. but I had to delete the folder before launching the import

    It looks like the import tries to unzip again and deletes the folder before importing.

    Looks like a bug to me, just posted issue

Please Sign in or register to post replies

Write your reply to: