Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Wolfram Kraus 7 posts 107 karma points
    Jan 17, 2017 @ 12:19
    Wolfram Kraus
    0

    Mixed languages in umbraco backend

    Hello all!

    The following problem is driving me nuts: We have an umbraco installation with mixed languages in the backend. When I switch the language for my user to "English (United Kingdom)" I still see some german words in the backend, e.g. "Durchsuchen" instead of "Type to search..." in the search box or "Entwickler" instead of "Developer", but not everywhere as you can see in the following screenshot: enter image description here

    The default ui language is set to "EN"

    <add key="umbracoDefaultUILanguage" value="en" />
    

    Any tips or hints how to fix this?

    Update:

    Looking through packages.config I saw that these additional packages were installed:

    • Microsoft.AspNet.Mvc.de
    • Microsoft.AspNet.Razor.de
    • Microsoft.AspNet.WebPages.de

    I uninstalled them via nuget console, cleared the cache, removed App_Data, bin and obj and cleaned the project, but that still didn't help.

  • NDDT 68 posts 239 karma points c-trib
    Jan 19, 2017 @ 09:30
    NDDT
    0

    Thats odd. I'm assuming that you have deleted your cache.

    Are there any javascript errors?

  • Wolfram Kraus 7 posts 107 karma points
    Jan 19, 2017 @ 09:37
    Wolfram Kraus
    0

    Yes, deleted the cache, cleaned the project, deleted obj/ and bin/, tested on different browser with different os. Always the same behaviour.

    Even when switching to e.g. Spanish some words still remain German.

    Forgot to mention: No Javascript errors in the console despite a "Failed to load resource" for the favicon

  • Wolfram Kraus 7 posts 107 karma points
    Jan 20, 2017 @ 07:32
    Wolfram Kraus
    100

    I could not find the reason for this really weird behaviour, so I went for a pragmatic solution: I replaced Umbraco\config\lang\de.xml with Umbraco\config\lang\en.xml and adjusted the attributes in the language element.

    Now all german user see the backend completely in English, but that's not so annoying as for english user to see a mixed german-english backend.

  • Ingrid Lootsma 5 posts 75 karma points
    Feb 01, 2019 @ 12:17
    Ingrid Lootsma
    0

    We're still experiencing this issue in Umbraco 7.10.4 (Dutch and English mixed in the interface, no matter if we select Dutch or English for the default and/or user language).

    Anyone resolve this issue?

  • MuirisOG 366 posts 1224 karma points
    Feb 04, 2019 @ 13:21
    MuirisOG
    0

    I haven't experienced this, but have you checked your browser language setting?

    Does it happen in all browsers?

    Muiris

Please Sign in or register to post replies

Write your reply to:

Draft