Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sven Temmerman 5 posts 75 karma points
    Apr 14, 2017 @ 13:33
    Sven Temmerman
    0

    HTTP Error 403.14 - Forbidden when accessing /umbraco

    Hi,

    I've been trying to install Umbraco for two weeks now at a hosting company. Many things went wrong but finally, I can see the front end: http://aleenbe.webhosting.be.

    I still have a problem when trying to access the umbraco backend. I get an error saying that no default document can be found, which results in an http error 403.14.

    I've installed Umbraco 7.5.6. This is running perfect on my dev machine. The problem must be a setting in IIS 8.5, but I don't even know where to start looking.

    Anyone faced this problem in the past? Anyone can help me out with this?

  • Marc Goodson 617 posts 3810 karma points MVP 3x c-trib
    Apr 16, 2017 @ 18:52
    Marc Goodson
    0

    Hi Sven

    Can you check which mode the app pool pipeline is running in for the site ?

    eg with 'Classic Mode' in IIS, in the olden days, you'd need to configure a default document eg default.aspx to load when pointing at a folder...

    but in IntegratedMode, there is no need the request is mapped to .net when there is no file extension.

    so my guess is your request to

    http://aleenbe.webhosting.be/umbraco

    is looking for

    http://aleenbe.webhosting.be/umbraco/default.aspx which doesn't exist, then trying to list the directory content which your local account doesn't have permissions to do hence the 403.

    switching to IntegratedMode should make the /umbraco url work once more.

    regards

    Marc

  • Sven Temmerman 5 posts 75 karma points
    Apr 17, 2017 @ 08:40
    Sven Temmerman
    0

    Hi Marc,

    I justed checked it and the app pool is running in Integrated Mode.

    I also see that the app pool is running in 64-bit but with 32-bit enabled. Could that be causing the problem?

    Ragards, Sven

  • Sven Temmerman 5 posts 75 karma points
    Apr 29, 2017 @ 13:18
    Sven Temmerman
    0

    In order to fix this the hosting company put a web.config file in the umbraco folder containing the following

    <configuration>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        </system.webServer>
    </configuration>
    

    After doing this the backend started working. I also noticed the same problem in the App_Plugin folder. Adding the same web.config file solved all the problems ....

  • Marc Goodson 617 posts 3810 karma points MVP 3x c-trib
    Apr 29, 2017 @ 19:21
    Marc Goodson
    0

    Hi Sven

    Glad you have something running!

    So it does seem connected to the mode the pipeline is running in.

    Reading about that setting here:

    https://www.iis.net/configreference/system.webserver/validation

    it's there to detect whether an ASP.Net application that is setup to run in Classic.Net mode needs to be changed in order to function correctly in Integrated mode (default is true)

    but what confuses me is your Umbraco site should run fine in integrated mode...

    regards

    Marc

Please Sign in or register to post replies

Write your reply to:

Draft