Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Hundebol 167 posts 314 karma points
    May 19, 2017 @ 06:31
    Hundebol
    0

    Upgrading to umbraco 7.6.1 shows log4net error

    Hi umbracians,

    I've recently tried to upgrade my 7.5.10 site to 7.6.1

    When launching the site after copying new files and merging configs, i now get log4net errors.

    The file or the assembly 'log4net, Version = 1.2.11.0, Culture = neutral, PublicKeyToken = null' or one of its dependencies could not be loaded
    

    i says in the docs there are breaking changes to log4net, so no surprise there. But what are the correct steps to make to get it to work?

    What I did:

    1. Copied the new log4net.dll to the site
    2. Updated the web.config with the new log4net assembly binding

    Is this the correct way of doing the upgrade?

    best regards

  • Alex Skrypnyk 5533 posts 20809 karma points MVP 3x admin c-trib
    May 19, 2017 @ 07:23
    Alex Skrypnyk
    0

    Hi Hundebol

    You need to merge web.config with your local, there are few changes, not only new log4net assembly binding. Try to use WinMerge for merging configs.

    Thanks,

    Alex

  • Hundebol 167 posts 314 karma points
    May 19, 2017 @ 07:30
    Hundebol
    0

    Hi Alex,

    Of course i have merged the other changes as well :)

    This is what is shown in the 7.6.1 web.config

      <dependentAssembly>
        <assemblyIdentity name="log4net" publicKeyToken="669e0ddf0bb1aa2a" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-2.0.8.0" newVersion="2.0.8.0"/>
      </dependentAssembly>
    

    There is no such thing in my current web.config

  • Hundebol 167 posts 314 karma points
    May 19, 2017 @ 09:54
  • Hundebol 167 posts 314 karma points
    May 22, 2017 @ 06:35
    Hundebol
    0

    Well - it worked momentarily. I keep getting errors and in the end the Application Pool stops. So not good.

    Anyone got another fix?

Please Sign in or register to post replies

Write your reply to:

Draft