Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Joshua Lemli 52 posts 234 karma points
    May 19, 2017 @ 17:05
    Joshua Lemli

    Moving Umbraco site give YSOD, "the view found at ... was not created"

    After moving my site to a new directory and subdomain, I always get the YSOD plus the error "The view found at .... was not created" (System.InvalidOperationException) . I can still login to the backoffice, but ALL published content yields the "view not created" YSOD.

    I tried this with a clean install of Umbraco with only one published content item today. Steps:

    • Copy Umbraco site to new directory and set permissions
    • Copy Umbraco database
    • Change db-connection string in cloned web.config to point to cloned db
    • Add new "Site" in IIS8 pointing to the cloned Umbraco directory

    Some things I have tried:

    • Delete ~/App_Data/umbraco.config
    • Clear browser cache
    • Republish Umbraco to cloned directory with MS Visual Studio
    • Republish content from within Backoffice (Content > Republish All)

    None of these fix anything. This is a major problem as I need to move some Umbraco sites from their dev location to a production location.

  • Joshua Lemli 52 posts 234 karma points
    May 19, 2017 @ 17:55
    Joshua Lemli

    After much in-depth tinkering, I believe I have found a very simple (albeit tedious) solution to my problem.

    Steps to resolve issue:

    Open the backoffice and...

    1) Republish each individual content item (under Content)

    2) Save each individual template (under Settings > Templates)

    3) Save each individual document type (under Settings > Document Types)

    I have to test this other sites but it worked for one site already. Using IIS8, Windows Server 2012 R2, Umbraco 7.6.1, MS Visual Studio 2017.

Please Sign in or register to post replies

Write your reply to: