Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Anthony 20 posts 137 karma points
    Jun 10, 2017 @ 21:58
    Anthony
    0

    Umbraco Package Installation Issues in Debug but not Release

    Quite simply, I can't install packages in Umbraco when running in Debug mode. This includes any of the starter kits when running the installer. However, if I run Umbraco under Release <compilation ... debug="false "... > then packages work and so do the starter kits if selected on install.

    If I try and install a package the log shows this error:

    _shutDownMessage=CONFIG change
    HostingEnvironment initiated shutdown
    CONFIG change
    HostingEnvironment caused shutdown
    
    _shutDownStack=   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
       at System.Environment.get_StackTrace()
       at System.Web.Hosting.HostingEnvironment.InitiateShutdownInternal()
       at System.Web.Hosting.HostingEnvironment.InitiateShutdownWithoutDemand()
       at System.Web.HttpRuntime.ShutdownAppDomain(String stackTrace)
       at System.Web.Configuration.HttpConfigurationSystem.OnConfigurationChanged(Object sender, InternalConfigEventArgs e)
       at System.Configuration.Internal.InternalConfigRoot.OnConfigChanged(InternalConfigEventArgs e)
       at System.Configuration.BaseConfigurationRecord.OnStreamChanged(String streamname)
       at System.Web.Configuration.WebConfigurationHostFileChange.OnFileChanged(Object sender, FileChangeEvent e)
       at System.Web.DirectoryMonitor.FireNotifications()
       at System.Web.Util.WorkItem.CallCallbackWithAssert(WorkItemCallback callback)
       at System.Web.Util.WorkItem.OnQueueUserWorkItemCompletion(Object state)
       at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
       at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
       at System.Threading.ThreadPoolWorkQueue.Dispatch()
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
    

    The packages download to the App_Data folder but aren't installed - the browser window refreshes.

    The development set-up I'm using is MSVC 2015, with Umbraco created from an empty project and installed using Nuget (Install-Package UmbacoCms). F5, click text to add debug='true' to the web.config and configure to use with SQL CE. (I've tested with LocalDB and SQL Server too). MSVC defaults to use IIS Express (I've tried IIS 10). So, it's pretty much a vanilla install of 7.6.3.

    I don't think it's a file permission issue, as it all runs under my user account and I have full privileges. Besides why would Release work and Debug fail if that were the case?

    To be honest I'm not sure when the issue started, I don't tend to play around with packages that often, and everything else "seems" to be working. I do have MSVC 2017 installed too and I recently installed some C++ Development tools. My windows edition is 14393.

    This issue would seem to be related to these issues: https://our.umbraco.org/forum/getting-started/installing-umbraco/72398-hostingenvironment-initiated-shutdown (I've tried without Virus protection and that doesn't seem to make a difference.)

    Frankly, I'm stumped. Help would be appreciated.

  • Anthony 20 posts 137 karma points
    Jun 14, 2017 @ 20:26
    Anthony
    0

    One thing I didn't mention above was that this behaviour was happening on all versions of Umbraco back as far as v7.5 - at which point I stopped testing them.

    There was also an element of file permissions failure, like the package files couldn't be unzipped properly. It was all very unpleasant and flakey.

    My best hunch as to the cause of the issue was that my development machine had become "confused" by having MSVC 2013, 2014, 2015 installed alongside a wide variety of Powershell and other language frameworks and toolkits.

    Eventually I lost my patience: noting that the Umbraco installation guide only covers up to 2015 I tried uninstalling MSVC 2017 but that didn't resolve the issue. So I tried a fresh Windows 10 install with just MSVC 2015 and that, as you'd expect, worked perfectly.

    I'll be slowly reapplying the development layers over the next few weeks and months, keeping careful backups, and will post back if I find a definite culprit, but at the moment I don't know what the cause was :(

  • Anthony 20 posts 137 karma points
    Jan 25, 2021 @ 11:37
    Anthony
    0

    Had a similar issue this morning and thought I'd check back through my forum posts as it seemed familiar...

    The problem: on a fresh development build using MSVC 2017, Umbraco 7.13, in both debug and release, packages wouldn't install.

    The issue was related to TLS1.0 being disabled. The error in the logs was

    Umbraco.Core.Exceptions.ConnectionException: An error occuring downloading the package from https://our.umbraco.com/webapi/packages/v1/ced954d1-8c0f-4abe-bdda-99e7a787d052?version=7.13.2&includeHidden=true&asFile=true ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
    

    Reading this post I found Paul Seal's package which allows an existing Umbraco website to run over TLS1.2. Download and installing this package locally resolved the issue. Paul has a blog which explains the code installed. Thanks Paul.

    I suspect this issue is related to the package server refusing TLS1.0 connections and the underlying ASP.NET code not retrying with TLS1.2. The change here connects with TLS1.2 and retries with TLS1.0 if that fails.

Please Sign in or register to post replies

Write your reply to:

Draft