Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fuji Kusaka 2203 posts 4220 karma points
    Jul 14, 2017 @ 15:24
    Fuji Kusaka
    0

    Hi guys,

    Just a few questions about umbracofilesystemprovidersazure. After the install and fully copied all the files to my blobstorage only new uploaded images get the expected blog.core.net url. Is that normal you should i be expecting the previous ones to get the new url ? right now this is what i get in the front end " http://sitename/media/1234/0384.jpg" instead of "https://blob.core.windows.net/media/1234/0384.jpg".

    Btw am on 7.5.13 on this project.

    Thanks,

  • Jeavon Leopold 3042 posts 13382 karma points MVP 9x admin c-trib
    Jul 17, 2017 @ 10:42
    Jeavon Leopold
    0

    Hey Fuji,

    All urls should be always be like "http://sitename/media/1234/0384.jpg" but under the hood the "media" is virtualized so that all files are stored in the blob account...

    So now I'm confused how you see blob.core addresses on the front end?

    Jeavon

  • Fuji Kusaka 2203 posts 4220 karma points
    Jul 17, 2017 @ 12:38
    Fuji Kusaka
    0

    Hey Jeavon,

    Well after moving all the files to the blob storage everything worked as expected with the "http://sitename/media/1234/0384.jpg". Then with new uploads it started to display the blob.core address.

    Am trying to replicate same on a latest version 7.6.4 to see what is the outcome.

  • Jeavon Leopold 3042 posts 13382 karma points MVP 9x admin c-trib
    Jul 17, 2017 @ 12:40
    Jeavon Leopold
    0

    Did you install with the Umbraco package or NuGet and then manually made the config changes?

  • Fuji Kusaka 2203 posts 4220 karma points
    Jul 17, 2017 @ 12:55
    Fuji Kusaka
    0

    i just tried same with v7.6 and did the configuration in the backend directly. Works as expected with no blob.core urls.

  • Fuji Kusaka 2203 posts 4220 karma points
    Jul 17, 2017 @ 12:43
    Fuji Kusaka
    0

    UmbracoPackage and manual config, instead of doing the configuration directly from backend.

  • Fuji Kusaka 2203 posts 4220 karma points
    Jul 17, 2017 @ 13:01
    Fuji Kusaka
    100

    Jeavon, found it !!

    I have the AzureBlobFileSystem set to true !!

    <add key="AzureBlobFileSystem.DisableVirtualPathProvider" value="true" />
    

    Thats why for new uploads its displaying the blob.core address both back & frontend.

  • Jeavon Leopold 3042 posts 13382 karma points MVP 9x admin c-trib
    Jul 17, 2017 @ 13:04
    Jeavon Leopold
    0

    Oh ok, not sure that's supposed to have the effect although I haven't ever used it.....

    Great you've fixed it though!

  • organic 108 posts 157 karma points
    Feb 18, 2021 @ 22:29
    organic
    0

    I can confirm the same behavior in 8.11.1. Setting:

    <add key="AzureBlobFileSystem.DisableVirtualPathProvider" value="true"/>
    

    causes Media uploads to set the url to https://???blobstorage.blob.core.windows.net/[containerName]/[folderName]/[fileName] and that renders a fully-qualified absolute path to the public page for the media item. I still wonder what the intended use of this appSetting is. As I mention here, I have installed the package via both NuGet and the back office: https://github.com/umbraco-community/UmbracoFileSystemProviders.Azure/issues/183

    In my case, I'm trying to allow Media to circumvent Azure AD app authentication so this is helpful, but since the same 'bug' doesn't happen for existing Media it's not helpful enough to solve my problem.

Please Sign in or register to post replies

Write your reply to:

Draft