Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Daryl 5 posts 75 karma points
    Aug 02, 2017 @ 11:29

    Multi Node Tree Picker 2 Filtering Issue

    I am currently working on a project where I need to include a Multi Node Tree Picker, yet restrict what the user can select. Looking at the object, there is a field "Allow Items Of Type" where I need to input the alias of the document type that I wish to allow the user to select.

    The issue lies in the fact that this functionality does not seem to be doing anything, as I am still able to select whichever item I want, regardless of what is input in the previously mentioned field. I have even tried to use to dictate this negatively, by inputting what I do NOT want the user to be able to select (by inputting "!" before the alias name), however I was met with the same result.

    Any help regarding this issue would be greatly appreciated.

    Thank you

  • Alex Skrypnyk 5272 posts 19275 karma points MVP 3x admin c-trib
    Aug 02, 2017 @ 13:09
    Alex Skrypnyk

    Hi Daryl

    Can you check, please, what property editor are you using on the page?

    Because it can be a situation when you edit a field "Allow Items Of Type" for wrong property editor.



  • Daryl 5 posts 75 karma points
    Aug 03, 2017 @ 15:45

    Hi Alex,

    The property Editor is Umbraco.MultiNodeTreePicker2

    Thank you for replying


  • Niels Lynggaard 172 posts 469 karma points
    May 15, 2018 @ 07:34
    Niels Lynggaard

    Still seeing this issue!

    I've set up MNTP 2 to allow items of documenttype "speaker", but I am allowed to pick anything under a "speaker" node as well, ("talks").. Is this a known issue?


  • Mike Masey 29 posts 201 karma points MVP c-trib
    May 29, 2018 @ 09:16
    Mike Masey

    I just stumbled across the same issue. I think it may be related to if you are using list view. When i have it enabled, it doesn't work correctly, but turning it off fixed it.

  • James 12 posts 83 karma points
    Jul 11, 2018 @ 22:48

    Same here, was pulling my hair out until I disabled the list view for the doc types I was selecting. Works, but a fix would be nice.

  • Mike Masey 29 posts 201 karma points MVP c-trib
    May 29, 2018 @ 09:19
    Mike Masey

    Just found an open issue on it too.

  • Dempsey 8 posts 88 karma points
    Jun 06, 2018 @ 13:28

    I too stumbled across this isue with the MNTP2. When you set it up to only allow items of a certain documenttype, that works, but it also allows all children of that document type to be selected, which can be a different kind of document type.

    I want the MNTP to only allow the selected document type to be selected.

    Anyone have a suggestion?

  • Welshrat 1 post 71 karma points
    Jun 08, 2018 @ 18:52

    Seeing the same issue here. I have Category and SubCategory and it allowing me to select SubCategory as a Category which isn't what I want.

  • z4kk 24 posts 78 karma points
    Jul 06, 2018 @ 12:54

    Same issue Umbraco version 7.11.0

    Any suggestions? =\

  • Adriana Cerqueiro 35 posts 174 karma points
    Aug 16, 2018 @ 16:27
    Adriana Cerqueiro

    Hi all, I am having a slightly different problem.

    I can select two things, the doctype that I am allowing (I don't have any child doctypes under that one) but I can also select the current node where the property is.

    Aside from that, I can't select anything else in the tree.

    The problem site is running on 7.12.0, but I have a functional one running on 7.11.0

    Thanks in advance,


  • Sebastiaan Janssen 4838 posts 14286 karma points MVP admin hq
    Aug 17, 2018 @ 06:34
    Sebastiaan Janssen

    Hi Adriana - this is a bug in 7.12.0, we've hopefully got a fix, check out this topic for more info and a temporary workaround you can try:

  • Adriana Cerqueiro 35 posts 174 karma points
    Sep 25, 2018 @ 12:54
    Adriana Cerqueiro

    Hi Sebastiaan, sorry for the late reply. I was on holiday and then I had to deal with other projects.

    I tried the solution on the post that you recommended and it didn't work.

    Now I have another project that I just updated (from 7.12.0 to 7.12.3) and it still doesn't work -I checked and on line 4344 is the code you mentioned in the other post-

    I am not using the MNTP2 in a Nested Content Doctype. The "allow items of type" has one value (although it doesn't work if I add more either) and the "Node type" is set to Content with the start node left blank.

    The content tree is still opening on the current node and it's not respecting the "allow items of type", allowing me to select anything on the tree.

    enter image description here

    I have no idea what else it could be. Please, let me know if you have any ideas.


  • shinsuke nakayama 105 posts 246 karma points
    Nov 23, 2018 @ 05:23
    shinsuke nakayama

    Hi Adriana,

    There is a work around for this. If you just select "Node type" of "Content", then it won't work. However, if you also click on "+ Choose..." then the textbox will appear. Inside the text box, if you type in the xpath, then it will only allow the type you have identified.

    If you type $site, then it will allow you to select from current site.

    e.g. my screenshot below

    enter image description here



  • Steven McCurrach 5 posts 95 karma points
    Jan 28, 2019 @ 15:58
    Steven McCurrach

    Selecting $site using xpath does prevent you from being able to pick other doctypes, but only if they aren't using a list view.

    If your doctype uses a list view, it's still accessible from the tree picker.

    Tried suggested fix in the solution thread above, by updating Umbraco/Js/umbraco.controllers.js with the supplied code, checked it was being loaded in using DevTools and was still able to access different doctypes I hadn't specified.

    This is as of v7.12.4 (UmbracoCloud, if it makes a difference).

  • Dmitriy 135 posts 490 karma points
    Feb 18, 2019 @ 14:43

    Same issue in Umbraco 7.13.2 :(

    The same conditions in my case: listview enabled.

    Selecting $site using xpath does prevent you from being able to pick other doctypes, but only if they aren't using a list view.

    Steven's McCurrach advise solved the problem, even if listview has been enabled, but that kind of behavior is weird anyway

  • Raluca Dumitru 19 posts 128 karma points
    May 16, 2019 @ 10:56
    Raluca Dumitru

    Same happens in Umbraco 8. Disabling list view seems to be the solution.

Please Sign in or register to post replies

Write your reply to: