Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • cole young 20 posts 41 karma points
    Aug 14, 2017 @ 21:47
    cole young
    0

    All files in Umbraco/dialogs folder return 404 not found

    I have a site in production that is almost working. The published pages all work. Some of the backend pages return a 404 error. I have gone over the permissions with a fine toothed comb.

    This started not working after we added an SSL cert to the server. It works on the dev server which does not have an SSL cert.

    Windows server 2012 R2 datacenter, IIS 8.5, Umbraco 7.5.8

    Specific example: If I click the preview button, the page opens and displays a 404 error. If i look in Chrome's dev tools, i see that https://mywebsite.com/umbraco/dialogs/Preview.aspx?id=2233 threw a 404 error in the ajax call.

    none of the files in the dialogs folder are found.

    It look like a permissions problem, but i have run this batch file again and again.

    icacls App_Code /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls App_Browsers /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls App_Data /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls App_Plugins /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls bin /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls config /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls fonts /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls images /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls Media /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls Properties /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls scripts /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls styles /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls Umbraco /grant "IIS APPPOOL\%1":(OI)(CI)F
    icacls Umbraco_Client /grant "IIS APPPOOL\%1":(OI)(CI)F
    icacls Views /grant "IIS APPPOOL\%1":(OI)(CI)M
    icacls Web.config /grant "IIS APPPOOL\%1":(OI)(CI)F
    icacls Web.config /grant "IIS APPPOOL\%1":F
    

    I also made sure that the file list in that folder matches the file list on the dev server. I can open those files, edit them, and save them.

    Does anyone have another idea what could be going on?

  • cole young 20 posts 41 karma points
    Aug 17, 2017 @ 16:53
    cole young
    0

    Additional notes:

    It does not appear to be permissions. I can access the images, css, js files in the umbraco folder. i cannot access any aspx files in the umbraco folder.

    I have discovered that the production server has URL Authorization installed under Web Server(IIS)->Web Server->Security. The server dev server which works does not have this installed.

    I am still searching for a solution.

    Does anyone know how to grant access to the aspx files in the umbraco folder to logged in users?

  • cole young 20 posts 41 karma points
    Aug 17, 2017 @ 20:20
    cole young
    0

    more notes:

    I created an html file in the root and was able to access it externally. i renamed it test.aspx and got a 404 when i tried to access it. All the aspx files on the site are returning a 404.

    Can anyone help give me some direction?

    i have installed around 60 umbraco sites and this has never happened before.

    I have spent hours in this forum and all over google. i feel like i am just asking the wrong question.

    Thanks, Cole

  • Nigel Wilson 904 posts 1979 karma points
    Aug 17, 2017 @ 20:31
    Nigel Wilson
    0

    Hey Cole

    Sorry to ask, but have you tried other browsers and/or incognito mode ?

    Cheers

    Nigel

  • Nicholas Westby 1880 posts 6255 karma points c-trib
    Aug 17, 2017 @ 20:54
    Nicholas Westby
    0

    IIS requires ASP.NET to be installed in order for ASPX files to work. When you configure the features for IIS, you should be able to select ASP.NET as one of those features.

    Instructions here under "To install IIS and ASP.NET modules on Windows Server 2012 using the UI": https://technet.microsoft.com/en-us/library/hh831475(v=ws.11).aspx

  • cole young 20 posts 41 karma points
    Aug 17, 2017 @ 22:08
    cole young
    0

    @Nigel,

    Other browsers and incognito mode make no difference. Thanks for the suggestion.

  • cole young 20 posts 41 karma points
    Aug 17, 2017 @ 22:11
    cole young
    0

    Nicholas,

    I have confirmed that ASP.NET is installed on the server. Both 3.5 and 4.5 are installed.

    I am thinking of uninstalling and re-installing them to see if it that fixes the problem. I have to wait for the site to be moved to a temp server as they won't allow any downtime.

    Thanks for the input.

  • Sven Vervloet 3 posts 73 karma points
    Apr 17, 2019 @ 09:32
    Sven Vervloet
    0

    Did you ever solve the problem? I'm experiencing the same thing. The site was recently given a SSL certificate

  • Paul Wright (suedeapple) 208 posts 581 karma points
    Apr 17, 2019 @ 12:00
    Paul Wright (suedeapple)
    0

    Double check your folder structure and remove any "empty" folders, as some of these got replaced with Controller Routes (Especially with the "preview" stuff)

  • cole young 20 posts 41 karma points
    Apr 17, 2019 @ 14:56
    cole young
    0

    @Sven - I eliminated everything else but re-installing .net. I was not able to test that theory due to circumstances. I am convinced it would have corrected the problem but i have no proof.

    If you recently installed SSL cert, make sure that you follow the instructions for using SSL with the Umbraco backend before trying the above.

    Sorry to keep editing, but its been since 2017. There is a command line instruction that you can run to update the registry that .net is installed. I was on a hosted server and did not have commend line access. My work around for that was to uninstall ,net and reinstall it.

    I hope you get it solved.

  • cole young 20 posts 41 karma points
    Apr 17, 2019 @ 15:05
    cole young
    0

    @Paul - my specific problem was that all aspx/ascx files were coming up 404. All my google research pointed to refreshing the .net install. I do appreciate your suggestion, but i can't test it as that site is no longer available.

Please Sign in or register to post replies

Write your reply to:

Draft