Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • 3ijtKwijt 36 posts 215 karma points
    Aug 24, 2017 @ 09:23
    3ijtKwijt
    0

    Auto publish / unpublish not working?

    Hi there,

    I'm using Umbraco 7.6.4 and somehow when I was testing the auto publish and auto unpublish feature, this doesn't seem to work at all as it never gets published / unpublished...

    I've looked the issue up earlier, and tried the solutions I found, but it didn't helped much... I've also tried adding the url in the umbracoSettings in the web.routing part umbracoApplicationUrl

    But this didn't seem to help either...

    Update: I just tried it again, clicked on save, and saw this error in my logs:

     2017-08-24 11:50:38,046 [P22000/D37/T54] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - Request failed with status code "Unauthorized". Request content = "".
    System.Net.Http.HttpRequestException: Request failed with status code "Unauthorized". Request content = "".
    

    Update: I have changed the authentication settings for the /Umbraco folder to enable annonymous and now I don't get any errors in my logs anymore, but it also still doesn't publish / unpublish on the given time...

    Update: Have been trying some more things and it seems that right now the auto publish function works, sadly the auto unpublish doesn't work yet...

    Update: Sometimes it seems to work, other times it doesn't? o-o

    Does anyone have a clue on what might solve this?

    Thanks in advance!

  • 3ijtKwijt 36 posts 215 karma points
    Aug 24, 2017 @ 10:52
    3ijtKwijt
    100

    Well, the issue seems to be fixed after enabling Anonymous Authentication for the /Umbraco directory.

    Even though I had a bunch of issues with it not working / not working properly, this might maybe have been cause some cached things? Not sure, it was pretty weird, but it seems to be working now...

Please Sign in or register to post replies

Write your reply to:

Draft