Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • ismini 14 posts 135 karma points
    Oct 03, 2017 @ 09:45
    ismini
    0

    Hello,

    i use the latest version of umbraco (7.7.1) and i want to know if i can to download the files for translate in a different file from .xml ( for the example like word document or something like that).

    Thanks in advance.

  • Chriztian Steinmeier 2741 posts 8406 karma points MVP 6x admin c-trib
    Oct 03, 2017 @ 09:59
    Chriztian Steinmeier
    0

    Hi Ismini,

    I don't think that's possible — I do believe though, that the XML format it's an "official" translator format, which most translation tools are able to read.

    You may also want to know about this project, which makes managing translations a lot easier (I hear): https://our.umbraco.org/projects/backoffice-extensions/translation-manager/

    Hope that helps,

    /Chriztian

  • ismini 14 posts 135 karma points
    Oct 03, 2017 @ 14:12
    ismini
    0

    Thank you for the solution. I tried it and it works exactly as i want, but at the end i can't find how can i show the translate files in the content.

    Do you know if there is a documentation for this because i try to find one but i can't.

  • Kevin Jump 2136 posts 13510 karma points MVP 6x c-trib
    Oct 03, 2017 @ 14:38
    Kevin Jump
    0

    Hi Ismini

    There are some videos on how translation manager works :

    https://jumoo.co.uk/translate/videos/

    they might help you understand where the translated items go.

    Are you using the file provider ? if so you can either load the files back via the Translation Manager dashboard, or you can put them directly onto disk on your umbraco install (in the media/simple_translate folder).

    once the files are on the site, you can go to the Revived section of translation manager and review and approve the changes and they will be applied back onto the relevant area of the site.

  • ismini 14 posts 135 karma points
    Oct 10, 2017 @ 11:20
    ismini
    0

    Hi,

    I saw the videos and I saw something which I believe is the problem. In the first video I saw that in the left menu there is a tab with name "Translation Manager" which I can't see in my Umbraco.

    I use the 7.7.1 version of Umbraco.

    Do you know what is going wrong ?

    (Here a printscreen of my Umbraco) enter image description here

  • Kevin Jump 2136 posts 13510 karma points MVP 6x c-trib
    Oct 10, 2017 @ 12:02
    Kevin Jump
    0

    Hi

    Translation Manager is an additional package (not part of the default umbraco install). So you have to install it as a package for it to appear. (see https://our.umbraco.org/projects/backoffice-extensions/translation-manager/) This is a paid product so you will have to but a licence if you want to use it on your site - but it does make the translation stuff easier to manage. (i would say that as i wrote it)

    Inbuilt Umbraco Translations

    but if you are using the default umbraco stuff and that is working for you then you can import your translated xml by uploading it in the translation section :

    if you go to the node (either in Tasks assigned to me , or tasks created by me) then you get the option to download/upload the xml

    enter image description here

    when you upload the xml it will apply it to the translated node on the site and show you a preview. enter image description here

  • ismini 14 posts 135 karma points
    Oct 10, 2017 @ 12:13
    ismini
    0

    Yes, I know that. I have install the package in my Umbraco and i tried to use it for a test first (with free edition : "You will be limited to one set and one target language, for more target languages, please purchase a licence.") to see if it's that i want.

    Here a screenshot with settings :

    enter image description here

    and here a screenshot with translated files : enter image description here

    but i can't find they anywhere.

  • Kevin Jump 2136 posts 13510 karma points MVP 6x c-trib
    Oct 10, 2017 @ 12:19
    Kevin Jump
    100

    hi,

    yeah it looks like the translation section hasn't added its self (that was a bug in the first version on 7.7)

    you can add itself, by going to the user section and clicking on groups

    enter image description here

    then select the admin group

    enter image description here

    and then click on add in the sections list

    enter image description here

    from here you should be able to add the Translation Manager section.

    if you then submit and save, and refresh your browser the section should appear.

  • ismini 14 posts 135 karma points
    Oct 10, 2017 @ 12:25
    ismini
    0

    Ooohh.....thank you...! It's ok now :)

  • Kevin Jump 2136 posts 13510 karma points MVP 6x c-trib
    Oct 10, 2017 @ 12:29
    Kevin Jump
    0

    cool,

    if you have any other issues just pop something over in the forums for the package. https://our.umbraco.org/projects/backoffice-extensions/translation-manager/translation-manager-feedback/

    You might also want to make sure you are using the latest version (1.0.3) just to make sure you have any little fixes that have been done (there is nothing major, just little things like the section and file formatting)

Please Sign in or register to post replies

Write your reply to:

Draft