Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Francielle 65 posts 278 karma points
    Oct 18, 2017 @ 19:09

    GetSections error after upgrade to 7.7.3

    I upgraded my Umbraco 7.6.10 installation to Umbraco 7.7.3, but when I try to login to the CMS, I get this error on the console:

    "/umbraco/backoffice/UmbracoApi/Section/GetSections 500 (Internal Server Error)' and the menu inside the backoffice does not load:

    enter image description here

    There's also an error on the Log:

    ---> (Inner Exception #0) System.ArgumentNullException: Value cannot be null.
    Parameter name: source
       at System.Linq.Enumerable.Where[TSource](IEnumerable`1 source, Func`2 predicate)
       at Umbraco.Web.Trees.LegacyTreeDataConverter.ConvertFromLegacy(String parentId, XmlTreeNode xmlTreeNode, UrlHelper urlHelper, String currentSection, FormDataCollection currentQueryStrings, Boolean isRoot)
       at Umbraco.Web.Trees.LegacyTreeDataConverter.ConvertFromLegacy(String parentId, XmlTree xmlTree, UrlHelper urlHelper, String currentSection, FormDataCollection currentQueryStrings)
       at Umbraco.Web.Trees.ApplicationTreeExtensions.TryLoadFromLegacyTree(ApplicationTree appTree, String id, FormDataCollection formCollection, UrlHelper urlHelper, String currentSection)
       at Umbraco.Web.Trees.ApplicationTreeController.<GetRootForSingleAppTree>d__2.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Umbraco.Web.Trees.ApplicationTreeController.<GetApplicationTrees>d__0.MoveNext()<---
  • Marcio Goularte 251 posts 802 karma points
    Oct 19, 2017 @ 01:41
    Marcio Goularte

    Hi, Fran. This happened to me. It was a custom section that I had, which gave migration trouble. The update broke the permissions when resetting for groups. I accessed the users section by url, removed the custom section from the groups, saved, and added again

  • Francielle 65 posts 278 karma points
    Oct 19, 2017 @ 09:43

    Hi Marcio, That's weird, because I don't have any custom section. The only thing that added a new menu item under Developer section for me was the package Diplo Audit.

    I'll investigate a bit more.

  • Henrik Bäck 12 posts 72 karma points
    Oct 19, 2017 @ 08:35
    Henrik Bäck

    I have a similar problem, all sections are missing, but my stack trace is slightly different. I use Unity, and when I disable the registration of the Unity-container the backend works fine. I've upgraded from 7.6.10 as well.

    I've followed the instructions in but can't get any further.

    Any ideas?

    System.AggregateException  at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
       at Umbraco.Web.Editors.SectionController.GetSections()
    ---> Inner Exception: System.NullReferenceException at System.Object.GetType()
           at Umbraco.Web.Trees.ApplicationTreeExtensions.<TryGetRootNodeFromControllerTree>d__5.MoveNext()
        --- End of stack trace from previous location where exception was thrown ---
           at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
           at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
           at Umbraco.Web.Trees.ApplicationTreeController.<GetRootForMultipleAppTree>d__1.MoveNext()
        --- End of stack trace from previous loc
  • Francielle 65 posts 278 karma points
    Oct 19, 2017 @ 09:54

    Hi Henrik,

    Did you face any errors during the upgrade? I had some errors with the HealthCheck files and afterwards not being able to login to the cms, than I had to run the upgrade. I have a feeling that the upgrade actually was not successful (even if it finished), that's why there are these errors.

    There's nothing special about my project, no custom sections or custom development, it is just an institutional website. That's why it is weird having these errors.

  • Rune Antonsen 27 posts 141 karma points
    Oct 30, 2017 @ 14:36
    Rune Antonsen

    Hi Henrik!
    Did you find a solution for this?
    I'm having the exact same issue.

  • Henrik Bäck 12 posts 72 karma points
    Nov 01, 2017 @ 06:55
    Henrik Bäck

    Hi Rune!

    I have not solved this yet. Will look into this further on Friday.

    Do you use Unity or AutoFac as well?

  • Henrik Bäck 12 posts 72 karma points
    Nov 21, 2017 @ 09:53
    Henrik Bäck

    Hi Rune, did you solve this?

    I've spent the morning with this error and I've tried to remove Unity and set it up again as described here

    Same issue anyway. If I remove Unity, all works in Backend.

    My UnityConfig looks like this...

        public static void RegisterTypes(IUnityContainer container)
                new PerHttpRequestLifeTime(),
                new InjectionFactory(c => UmbracoContext.Current)
            container.RegisterTypes(AppDomain.CurrentDomain.GetAssemblies().SelectMany(x => x.GetTypes()));
            container.RegisterType<LegacyTreeController>(new InjectionConstructor());
            container.RegisterType<ISettingsProvider, UmbracoSettingsProvider>(new PerHttpRequestLifeTime());
            container.RegisterType<IMenuProvider, UmbracoMenuProvider>(new PerHttpRequestLifeTime());
  • Dirk De Grave 4496 posts 5828 karma points MVP 3x admin
    Jan 24, 2018 @ 14:42
    Dirk De Grave

    fwiw, if still struggling to get this working, just found out what needs changing to get it working with unity

            new HierarchicalLifetimeManager(),
            new InjectionFactory(c => UmbracoContext.Current));
        container.RegisterType<HealthCheckController>(new InjectionConstructor());
        container.RegisterType<UserTreeController>(new InjectionConstructor());
        container.RegisterType<Umbraco.Web.Editors.UsersController>(new InjectionConstructor());

    user section has changed quite a lot in v7.7.x, took me too much time to find out it's this specific part of the config that was failing

  • Francielle 65 posts 278 karma points
    Oct 19, 2017 @ 10:06

    I fixed my problem. On my /config/trees/config there were some custom sections added by packages Diplo.AuditLog and LeBlender and these were generating the error. Yesterday I had replaced the file, but it seems that it did not work. Today, I overwrote the file again with the one that comes in Umbraco's .zip and it worked.

  • Anders Brohäll 285 posts 546 karma points
    Oct 24, 2017 @ 20:39
    Anders Brohäll

    I'm having the same problem. No custom sections, and it works with everything except for the Users section. : /

    I described my config here:

    Did you guys solve it? (apart from Francielle) How?

  • Anders Brohäll 285 posts 546 karma points
    Oct 24, 2017 @ 21:20
    Anders Brohäll

    Turns out it was a Structure Map issue in our solution. All good now.

  • Laurence Gillian 593 posts 1207 karma points
    Feb 22, 2018 @ 17:54
    Laurence Gillian

    I've seen this error twice this week on two separate projects.

    The first was resolved by adjusting the IoC, but the second project does not have any 'direct' IoC, however I'm pretty confident it may be due to some other packages.

    Will see how far I can get with it, and post my findings.

    There's quite a good thread on Issues, but I wasn't able to find anything of use.

  • Laurence Gillian 593 posts 1207 karma points
    Feb 26, 2018 @ 16:11
    Laurence Gillian

    I was able to resolve my issue, by correctly manually merging the following files:


  • Martijn 2 posts 71 karma points
    Feb 27, 2018 @ 13:23

    Can you share your config files? I am having this problem as well but changing my config files doesn't seem to fix it.

    My config files look like this:

    <?xml version="1.0" encoding="utf-8"?>
      <add initialize="true" sortOrder="0" alias="content" application="content" title="Content" iconClosed="icon-folder" iconOpen="icon-folder" type="Umbraco.Web.Trees.ContentTreeController, umbraco" />
      <add initialize="false" sortOrder="0" alias="contentRecycleBin" application="content" title="Recycle Bin" iconClosed="icon-folder" iconOpen="icon-folder" type="umbraco.cms.presentation.Trees.ContentRecycleBin, umbraco" />
      <add initialize="true" sortOrder="0" alias="media" application="media" title="Media" iconClosed="icon-folder" iconOpen="icon-folder" type="Umbraco.Web.Trees.MediaTreeController, umbraco" />
      <add initialize="false" sortOrder="0" alias="mediaRecycleBin" application="media" title="Recycle Bin" iconClosed="icon-folder" iconOpen="icon-folder" type="umbraco.cms.presentation.Trees.MediaRecycleBin, umbraco" />
      <add initialize="true" sortOrder="0" alias="documentTypes" application="settings" title="Document Types" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.ContentTypeTreeController, umbraco" />
      <add application="settings" alias="templates" title="Templates" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.TemplatesTreeController, umbraco" initialize="true" sortOrder="1" />
      <add application="settings" alias="partialViews" title="Partial Views" silent="false" initialize="true" iconClosed="icon-folder" iconOpen="icon-folder" type="Umbraco.Web.Trees.PartialViewsTreeController, umbraco" sortOrder="2" />
      <add application="settings" alias="stylesheets" title="Stylesheets" type="umbraco.loadStylesheets, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="3" />
      <add application="settings" alias="stylesheetProperty" title="Stylesheet Property" type="umbraco.loadStylesheetProperty, umbraco" iconClosed="" iconOpen="" initialize="false" sortOrder="0" />
      <add application="settings" alias="scripts" title="Scripts" type="Umbraco.Web.Trees.ScriptTreeController, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="4" />
      <add application="settings" alias="languages" title="Languages" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.LanguageTreeController, umbraco" sortOrder="5" />
      <add initialize="true" sortOrder="7" alias="mediaTypes" application="settings" title="Media Types" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.MediaTypeTreeController, umbraco" />
      <add initialize="true" sortOrder="0" alias="packager" application="developer" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.PackagesTreeController, umbraco" />
      <add initialize="true" sortOrder="1" alias="dataTypes" application="developer" title="Data Types" iconClosed="icon-folder" iconOpen="icon-folder" type="Umbraco.Web.Trees.DataTypeTreeController, umbraco" />
      <add application="developer" alias="macros" title="Macros" type="umbraco.loadMacros, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="2" />
      <add application="developer" alias="relationTypes" title="Relation Types" type="umbraco.loadRelationTypes, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="4" />
      <add application="developer" alias="xslt" title="XSLT Files" type="umbraco.loadXslt, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="5" />
      <add application="developer" alias="partialViewMacros" type="Umbraco.Web.Trees.PartialViewMacrosTreeController, umbraco" silent="false" initialize="true" sortOrder="6" title="Partial View Macro Files" iconClosed="icon-folder" iconOpen="icon-folder" />
      <add initialize="true" sortOrder="0" alias="users" application="users" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.UserTreeController, umbraco" />
      <add application="users" alias="userTypes" title="User Types" type="umbraco.cms.presentation.Trees.UserTypes, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="1" />
      <add application="users" alias="userPermissions" title="User Permissions" type="umbraco.cms.presentation.Trees.UserPermissions, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="2" />
      <add initialize="true" sortOrder="0" alias="member" application="member" title="Members" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.MemberTreeController, umbraco" />
      <add initialize="true" sortOrder="1" alias="memberTypes" application="member" title="Member Types" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.MemberTypeTreeController, umbraco" />
      <add application="member" sortOrder="2" alias="memberGroups" title="Member Groups" type="umbraco.loadMemberGroups, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" />
      <add application="translation" alias="dictionary" title="Dictionary" type="umbraco.loadDictionary, umbraco" iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="0" />
      <add silent="false" initialize="true" sortOrder="1" alias="openTasks" application="translation" title="Tasks assigned to you" iconClosed="icon-folder" iconOpen="icon-folder" type="umbraco.loadOpenTasks, umbraco" />
      <add silent="false" initialize="true" sortOrder="2" alias="yourTasks" application="translation" title="Tasks created by you" iconClosed="icon-folder" iconOpen="icon-folder" type="umbraco.loadYourTasks, umbraco" />
      <!-- Custom -->
      <!--<add application="myApplication" alias="myTree" title="Me Tree" type="MyNamespace.myTree, MyAssembly"
           iconClosed="icon-folder" iconOpen="icon-folder" sortOrder="10" />-->
      <add initialize="true" sortOrder="8" alias="contentBlueprints" application="settings" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Web.Trees.ContentBlueprintTreeController, umbraco" />
      <add initialize="true" sortOrder="2" alias="datasource" application="forms" title="Datasources" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Forms.Web.Trees.DataSourceTreeController, Umbraco.Forms.Web" />
      <add initialize="false" sortOrder="0" alias="emailTemplates" application="forms" title="Email Templates" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Forms.Web.Trees.EmailTemplateTreeController, Umbraco.Forms.Web" />
      <add initialize="true" sortOrder="0" alias="form" application="forms" title="Forms" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Forms.Web.Trees.FormTreeController, Umbraco.Forms.Web" />
      <add initialize="true" sortOrder="3" alias="prevaluesource" application="forms" title="Prevalue sources" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Forms.Web.Trees.PreValueSourceTreeController, Umbraco.Forms.Web" />
      <add initialize="true" sortOrder="3" alias="formsecurity" application="users" title="Forms Security" iconClosed="icon-folder" iconOpen="icon-folder-open" type="Umbraco.Forms.Web.Trees.FormSecurityTreeController, Umbraco.Forms.Web" />
      <add initialize="true" sortOrder="0" alias="DataStore" application="DataStore" title="DataStore" iconClosed="icon-folder" iconOpen="icon-folder-open" type="W3S.DataStore.Models.Tree.DataStoreTreeController, DataStore" />


    <?xml version="1.0" encoding="utf-8"?>
      <add alias="content" name="Content" icon="traycontent" sortOrder="0" />
      <add alias="media" name="Media" icon="traymedia" sortOrder="1" />
      <add alias="settings" name="Settings" icon="traysettings" sortOrder="2" />
      <add alias="developer" name="Developer" icon="traydeveloper" sortOrder="3" />
      <add alias="users" name="Users" icon="trayuser" sortOrder="4" />
      <add alias="member" name="Members" icon="traymember" sortOrder="5" />
      <add alias="translation" name="Translation" icon="traytranslation" sortOrder="7" />
      <add alias="GCS" name="GCS" icon="icon-binoculars" sortOrder="20" />
  • Richard 41 posts 113 karma points
    Mar 13, 2018 @ 11:51

    What was the result?

Please Sign in or register to post replies

Write your reply to: