Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Søren Mastrup 101 posts 388 karma points c-trib
    Nov 20, 2017 @ 15:05
    Søren Mastrup
    0

    Cannot build umbraco 7.1.0 release

    Hi!

    After moving all of my old Umbraco installations to a new Windows 2016 server, I am getting the error "417 Missing token" on all my old umbraco installations below 7.3.0.

    I found this thread, that solves the problem:
    https://our.umbraco.org/forum/using-umbraco-and-getting-started/85747-417-missing-token-suddenly-occurring-on-all-our-sites#comment-271762

    I had no issues on compiling the releases above 7.2.x, but when trying to compile any release in 7.1.x I get the following errors: https://gist.github.com/anonymous/19f5f03f7c51acdfdada0e8f2ea13dd8

    When I look in the file SqlCEHelper.cs in the qlCE4Umbraco project I see this: https://i.imgur.com/yz8vERy.png

    I have no idea on how to fix this - Any suggestions?

  • Søren Mastrup 101 posts 388 karma points c-trib
    Nov 23, 2017 @ 14:51
    Søren Mastrup
    100

    Finally figured it out!

    It is neccessary to add the following lines to SqlCEHelper.cs to be able to compile:

    internal IRecordsReader ExecuteReader(string commandText)
    {
        return ExecuteReader(commandText, new SqlCEParameter(string.Empty, string.Empty));
    }
    
    
    internal int ExecuteNonQuery(string commandText)
    {
        return ExecuteNonQuery(commandText, new SqlCEParameter(string.Empty, string.Empty));
    }
    

    Thanks to Eric, from Umbraco, for pointing me in the right direction!

  • Bradley Irby 1 post 71 karma points
    14 days ago
    Bradley Irby
    0

    This is not a good sign for Umbraco. I pulled master branch and tried to build with 1600 errors, including a NuGet package that no longer exists (uGoLive). After removing uGoLive and pasting in the code above I was able to get a clean build.

    I can't even load the Umbraco.Web.UI project due to this error: error : The result "" of evaluating the value "$(WebPublishingTasks)" of the "AssemblyFile" attribute in element

    How can it be that a fix posted year ago that causes a broken build is still not included in the master branch? I was hoping to use Umbraco as my go-to CMS but this is giving me serious second thoughts as to whether the project is still supported.

Please Sign in or register to post replies

Write your reply to:

Draft