Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Christopher Dent 2 posts 92 karma points
    Jan 11, 2018 @ 21:13
    Christopher Dent

    Umbraco cannot start. A connection string is configured but Umbraco cannot connect to the database.

    I have a 7.7.4 site and have just recently tried to deploy it to my hosting platform and (for reasons that will become clear) to an AWS instance. On both deployments I am getting the error "Umbraco cannot start. A connection string is configured but Umbraco cannot connect to the database." and cannot figure out how to fix it.

    I first tried it on my hosting platform and wondering if their IIS settings were setup incorrectly I thought I would try an AWS instance and ended up with the same error. I can connect to the DB through SSMS using the details in the connection string (I've also tried Windows Auth), and with both giving the same result, I am starting to think it is not a connection issue.

    Any ideas are welcome as I've browsed through many forums and not come up with a solution yet.

    <remove name="umbracoDbDSN" />
    <add name="umbracoDbDSN" connectionString="Server=localhost;Database=****;Integrated Security=true" providerName="System.Data.SqlClient" />

    enter image description here

  • Alex Skrypnyk 4694 posts 16791 karma points MVP 2x admin
    Jan 12, 2018 @ 12:48
    Alex Skrypnyk

    Hi Christopher

    Is it ok that "Server=localhost"?

    If you are able to connect via MSSQL studio - usually umbraco works also



  • Josué González 17 posts 110 karma points
    Jan 12, 2018 @ 15:17
    Josué González

    Try this... Add your IIS AppPool\UmbracoAppPool application group as a login in SQL Server.

  • Christopher Dent 2 posts 92 karma points
    Jan 13, 2018 @ 19:06
    Christopher Dent

    After many hours I finally got this fixed!

    I had tried both authentication methods several times and had no luck either time but was hoping to avoid Windows Auth.

    I was looking at other sites I have that were working fine and examining the connection strings of those to see any differences I had missed and spotted that the password of one site was wrapped in single quotes!

    I added these in and it worked! Couldn't believe it was so simple after so many hours staring at it (and many, many, many forums and blog posts).

    Thanks for the fast responses.

    Hope this helps anyone with a similar issue to me

Please Sign in or register to post replies

Write your reply to: