Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ismail Mayat 4137 posts 8584 karma points MVP admin c-trib
    Jan 31, 2018 @ 10:20
    Ismail Mayat
    0

    Upgrade now cannnot log in

    Guys,

    I have just upgraded a site from 7.6.1 to 7.7.9 and when i hit site it wants me to login to run the upgrade however the credentials no longer work.

    I am not locked out checked the umbracoUsers table and i have useLegacyEncoding="true" still cannot login.

    Also looking at console output i get error 400 bad request

    Anyone seen this before.

    Regards

    Ismail

  • Pawel Bres 34 posts 145 karma points c-trib
    Jan 31, 2018 @ 10:57
    Pawel Bres
    0

    do you have DB backup before the upgrade? could you check if password hash didn't change?

  • Ismail Mayat 4137 posts 8584 karma points MVP admin c-trib
    Jan 31, 2018 @ 10:57
    Ismail Mayat
    0

    Pawel,

    Will check that in the db as its sql ce and checked into source control.

    Regards

    Ismail

  • Ismail Mayat 4137 posts 8584 karma points MVP admin c-trib
    Jan 31, 2018 @ 11:11
    Ismail Mayat
    0

    Pawel,

    No password hash has not changed.

    Regards

    Ismail

  • Pawel Bres 34 posts 145 karma points c-trib
    Jan 31, 2018 @ 21:00
    Pawel Bres
    0

    Ismail,

    I think I had this problem once, the solution was to do a progressive update, to every major version in between. In your case, it would be an upgrade to 7.0 and then to 7.7.9

  • Steve Morgan 964 posts 2998 karma points c-trib
    Feb 01, 2018 @ 08:34
    Steve Morgan
    0

    Hi,

    Could it just be a corrupt session - have you tried hitting the site from a browser you don't use or in incognito mode?

    I've seen some cookie / session issues mean I can't log in after upgrades.

    Guessing you've already tried this though?

    Steve

  • Nicholas Westby 1725 posts 5649 karma points c-trib
    May 02, 2018 @ 22:32
    Nicholas Westby
    0

    Ismail, did you ever figure this out?

  • Ismail Mayat 4137 posts 8584 karma points MVP admin c-trib
    May 03, 2018 @ 08:21
    Ismail Mayat
    0

    Not for this project but i did another upgrade had similar issue and fixed that my updating the web.config membership part also i did upgrade by creating blank umbraco site i wanted to upgrade to then pointed it to my existing db then did a deploy.

    Regards

    Ismail

  • Denford 90 posts 174 karma points
    May 02, 2018 @ 22:52
    Denford
    1

    had a similar issue a while ago not sure if exactly the same but, the old site used usernames to log in and after upgrade the default logic is to use email address.

    I remember having to edit the providers if the web config to allow the legacy way of logging in i.e.

    <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="4" useLegacyEncoding="true" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />
    

    Try that think the key setting is the use legacy encoding

  • Jeremy Henkes 2 posts 72 karma points
    May 16, 2018 @ 07:57
    Jeremy Henkes
    0

    I have the same issue after upgrading from 7.2.2 to 7.8.1. I tried how far I could go and up until 7.6.13, there are no problems. With 7.7.0, the login suddenly stops working. I always get the 'Authentication/PostLogin Internal Server Error (500)'.

    Things I've tried so far:

    • useLegacyEncoding true/false (true should be working in my case)
    • Copying web.config from a working project
    • Adding customHeaders for 'Access-Control-Allow-Origin' and 'Access-Control-Request-Headers' with value '*' in the web.config
    • Copying DB table layout (umbracoUser) from a working project (incl. rows)
    • Manually downloading/replacing umbraco files
    • Upgrading umbraco via nuget update
    • Checked userNoConsole=0
    • Deleting App_Data; resetting cache; incognito mode; deleting bin

    I've spent 3 hours searching for solutions but none seem to work for me. The login post request doesn't go through, because I can enter a wrong password as often as I want without the DB or log registering failed login attempts.

    Any other ideas I could try?

    Jeremy

  • Denford 90 posts 174 karma points
    May 17, 2018 @ 07:59
    Denford
    0

    Just out curiosity is your site on azure as a web app or on an actual server, cloud or otherwise. The reason why i ask is i noticed in my case was an azure app and i was deploying direct from visual studio and did notice some of the files were not being updated with the new 1s, especially the ones in the umbraco folders, so had to physically delete theme from the app then deploy again.

  • Jeremy Henkes 2 posts 72 karma points
    May 18, 2018 @ 09:22
    Jeremy Henkes
    0

    The site is hosted on an actual server. I've updated already several other sites to version 7.8.1 without any issues, but the previous version of these was always 7.5.x+.

    My next step will be to do a clean install of version 7.2.2 and update it to 7.8.1. I'll let you know whether the login works after that or not. If it does, then it's a configuration issue on my end.

    Jeremy

  • Nicholas Westby 1725 posts 5649 karma points c-trib
    May 18, 2018 @ 15:18
    Nicholas Westby
    0

    For anybody who is curious, my issue was a bug with the Umbraco core: http://issues.umbraco.org/issue/U4-11300

    In essence, Umbraco changed how users work for Umbraco 7.7, so you need to upgrade to that version first, and then you can upgrade to the latest version.

    That's probably the cleanest workaround. Somebody else posted another workaround though: http://issues.umbraco.org/issue/U4-11258#comment=67-46492

    Since my issue was actually a duplicate, I encourage anybody who runs into this to vote on the original issue: http://issues.umbraco.org/issue/U4-11258

  • Markus Johansson 1501 posts 4178 karma points
    21 days ago
    Markus Johansson
    0

    Just wanted to share that the the solution for me was to first go to 7.7.13 and then to latest version (at the moment 7.11.1)

Please Sign in or register to post replies

Write your reply to:

Draft