Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Craig100 1112 posts 2442 karma points c-trib
    Feb 17, 2018 @ 13:49
    Craig100
    0

    Can't Change User permissions as Admin

    Umb 7.5.8

    In a 7.5.8 site I've just inherited, I'm an Admin but can't set user permissions. All I see in a page's Action dropdown is "Send to publish", "Notifications" and "Reload". If I go to Users/User Permissions to assign myself all the permissions two scenarios happen. Either:

    Any checkbox I check shows "You do not have access to assign permissions to this node".

    OR:-

    If I check "Home" then "Content" in that order, I get a list of permissions to assign, all unchecked. If I check some then click Save I see the progress roller but it never completes.

    I had to use the Admin Reset package to assign myself as an Admin. I don't know if that's had any bearing on it.

    I'm a bit stuck.

    Any advice appreciated.

  • Joshua Lemli 52 posts 234 karma points
    Feb 19, 2018 @ 19:30
    Joshua Lemli
    0

    Umbraco allows creation of custom backoffice "roles". This means that someone could have created an "admin" role, assigned you to it, and removed your ability to control certain aspects from within the Umb. backoffice.

    This might be the case since you "inherited" the site. Do you have access to the user info that the site was setup with? This is the "root" admin and by default has full privileges.

Please Sign in or register to post replies

Write your reply to:

Draft