Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Andrew Cullen 137 posts 237 karma points
    Apr 09, 2018 @ 04:52
    Andrew Cullen
    0

    Switching back to UseLegacyEncoding=true

    So, I did something stupid and forgot to check the value of UseLegacyEncoding before pushing out my web.config after an upgrade (only on the dev server, thankfully). I've tried switching the value back to true, but I still can't log in to the backend to authorize the upgrade. I also tried the "forgot passowrd" link, but that fails as well. I was moving from 7.4.3 to 7.10.1, is that helps.

    Thanks!

  • Sebastiaan Janssen 5002 posts 15248 karma points MVP admin hq
    Apr 09, 2018 @ 06:59
    Sebastiaan Janssen
    0

    Did you check if you got locked out on the dev server due to too many invalid login attempts? You will probably have to reset the user in the database.

  • Andrew Cullen 137 posts 237 karma points
    Apr 09, 2018 @ 18:13
    Andrew Cullen
    0

    Thanks, Sebastiaan. I don't think the account is locked out; the lastLockoutDate and failedLoginAttempts are both NULL, and userDisabled is 0. Should I be checking anything else?

  • Andrew Cullen 137 posts 237 karma points
    Apr 10, 2018 @ 15:06
    Andrew Cullen
    100

    Ah ha! Found the solution here: https://our.umbraco.org/forum/using-umbraco-and-getting-started/88852-changing-uselegacyencoding-from-true-to-false

    I needed to add the useLegacyEncoding attribute to the UsersMembershipProvider, like so:

    <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco" useLegacyEncoding="true"/>
    
Please Sign in or register to post replies

Write your reply to:

Draft