Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Art Ardolino 2 posts 92 karma points
    1 week ago
    Art Ardolino
    0

    I purchased an Umbraco template called Constro and I'm trying to get the home page to load. When I run on an IIS server, I get a 404 error. I can navigate to my site http://mysite.com/umbraco to login, and I can also go to http://mysite.com/home-v1/ and the page loads.

    What I want is the root to go to the "Home v1" home page (same as http://mysite.com/home-v1). My understanding is that as long as the "Home v1" page is the first node under the main node, that this should be the home page.

    I tried setting the hostname under "Cultures and Hostnames" on the root node - still no luck.

    Any help someone can provide would be greatly appreciated. Thanks!

  • Jan Skovgaard 10886 posts 21519 karma points MVP 4x admin c-trib
    1 week ago
    Jan Skovgaard
    0

    Hi Art and welcome to the forum as well as to Umbraco :-)

    I must admit that I don't know anything about the theme you have bought.

    But the behaviour you describe sounds a bit odd. Can you please provide a screendump of the content section in your umbraco backoffice? I'm just wondering how things are organized and if you have a Root node setup, which contains the "Home" not below it etc. - Setting up the hostname should work. But it will make it easier to advice you if you let us see the setup of your content section.

    Also what exact version of Umbraco are you using?

    Cheers, Jan

  • Søren Gregersen 67 posts 284 karma points c-trib
    1 week ago
    Søren Gregersen
    0

    Hi,

    As I understand it, you have created a site (the root node) and then a sub-page (your frontpage (home-v1)). That setup results in the behaviour you describe.

    Are you able to move the frontpage to the root of your content-tree?

  • Art Ardolino 2 posts 92 karma points
    1 week ago
    Art Ardolino
    100

    Hi,

    I actually got it to work by setting the domain name under culture and hostnames option. I was originally doing this at the parent node, which didn’t work, but then when I did this on the page I wanted to be the home page, it worked. Thanks for your help.

  • Jan Skovgaard 10886 posts 21519 karma points MVP 4x admin c-trib
    1 week ago
    Jan Skovgaard
    0

    Hi Art

    Happy to hear you got it working - I had a suspicion that there was a rootnode containing the website, which was why I asked for a screendump to have it confirmed. But good to see you managed to figure it out anyway :-)

    /Jan

Please Sign in or register to post replies

Write your reply to:

Draft