Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Alistair Jenkins 92 posts 314 karma points
    Jun 21, 2018 @ 11:29
    Alistair Jenkins
    0

    Contents of Rich Text Editor not showing in back end

    Hi,

    My Umbraco installation has developed a strange fault. I have several Rich Text Editor fields which contain content entered when the back end was working properly, but now these show as blank when viewed in the Content section in the back end. If you preview the page the content is likewise missing.

    However, if you quit the back end and go to the live website the content is still there.

    No joy googling this issue. Can anyone explain why this is happening?

    Thanks, Alistair

  • Dan Diplo 1393 posts 5211 karma points MVP 2x c-trib
    Jun 21, 2018 @ 12:16
    Dan Diplo
    0

    Don't know the answer, but a few things to try:

    • Check the developer console in your browser for any messages / errors.

    • Clear your browser cache or run in an incognito window.

    • In web.config ensure debug="true" as this will bypass client
      dependency, which can occasionally cause issues.

    • Check the logs in /App_Data/Logs/ for any errors

    • Run the Data Integrity Health Check in Developer section

    • Republish the entire site

    Report back anything of interest!

  • Alistair Jenkins 92 posts 314 karma points
    Jun 21, 2018 @ 13:25
    Alistair Jenkins
    100

    Hi Dan.

    Thanks for replying.

    There was nothing in the developer window and I couldn't see anything in the rendered source code to suggest a solution.

    I had already tried doing a hard reload and empty cache while in the developer window.

    Then I tried republishing the page. This removed the missing content from the front page as well. So it seems the contents of the editors weren't just not displaying, they had been completely deleted somehow and when I republished the page the blanks showed up in the front end. Not sure how this happened but I've just copied over the original text from the dev site and now all is as it should be.

    Wonder how the text was deleted in the first place?

    Thanks again, Alistair

  • Jan Skovgaard 11152 posts 22857 karma points MVP 5x admin c-trib
    Jun 21, 2018 @ 14:54
    Jan Skovgaard
    0

    Hi Alistair

    Has there been any changes to document types, property editors etc. that has been deployed using uSync for instance?

    I'm asking because we had an issue using uSync where one of our developers had created some new properties on a document type manually on the live environment, which meant that we lost data when later another developer made changes locally, which he correctly deployed using uSync, which meant that the data fields had different id's and then we lost the data. But it was still there in the DB but the fields had another ID reference because the environments where out of sync.

    I hope my scenario makes sense? :-) Wondering if it could have been such an issue in your case?

    /Jan

  • Alistair Jenkins 92 posts 314 karma points
    Jun 21, 2018 @ 15:34
    Alistair Jenkins
    0

    Hi Jan,

    No changes were made to document types or property editors. I had been working on implementing Talkify in my website, could that have done something?

    Cheers, Alistair

  • Jan Skovgaard 11152 posts 22857 karma points MVP 5x admin c-trib
    Jun 21, 2018 @ 17:04
    Jan Skovgaard
    0

    Hi Alistair

    I highly doubt that it could have had anything to do with it but of course I don't know what you have touched in order to do so. But I can't imagine you have been doing anything data / database specific, which could have caused this.

    /Jan

  • Alan Feekery 5 posts 25 karma points
    Aug 28, 2018 @ 11:03
    Alan Feekery
    0

    I've had this happen a lot recently, it's like the RichTextBox control doesn't have it's content loaded in and renders empty.

    The only solution I can see is to roleback to bring the content back into the controls.

    The document type is big, 12 tabs with 7 RichTextBox controls in total...

Please Sign in or register to post replies

Write your reply to:

Draft