Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simone Chiaretta 134 posts 541 karma points c-trib
    Aug 09, 2018 @ 07:17
    Simone Chiaretta
    0

    Copy document creates new document as "admin", not as current user

    Hi, I've noticed a strange behavior and not sure if it's a bug or it's supposed to be like that.

    If I create a document, and then copy it, the original document is created as the current user, but the copies are created as "admin".

    Is this a bug? Picture shows the problem

    enter image description here

  • Jan Skovgaard 11264 posts 23592 karma points MVP 9x admin c-trib
    Aug 20, 2018 @ 11:23
    Jan Skovgaard
    0

    Hi Simone

    I just gave this a spin on Umbraco 7.12.

    I created a new user called "Editor" and logged in using this user to create a new document in my list and when I did the copy the user was listed under the "Created by".

    It worked as intended in this scenario. I also tried copying existing nodes that was created by the admin user and that would also display the name of the editor in the "Created by" column.

    What version did you experience this on?

    I was using e-mails like [email protected] and [email protected] in my scenarios for the user names. Not sure if it's relevant to mention but if the bug is due to some checking on a hardcoded value of "admin" for instance it might be.

    Looking forward to hearing from you :)

    /Jan

  • Nitin Anand 43 posts 174 karma points
    Dec 08, 2020 @ 10:52
    Nitin Anand
    0

    The issue still exists (7.5), maybe its a bug. Any workarounds?

Please Sign in or register to post replies

Write your reply to:

Draft