Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Olly Fray 11 posts 91 karma points
    Aug 14, 2018 @ 11:57
    Olly Fray
    0

    RTE in the grid, doesn't expand on first load

    Has anyone experienced issues with using the RTE within the grid?

    By default the RTE is minimised when first loading a node. Screen shot:

    enter image description here

    There is text within that box but the editor doesn't have any height, so it's uneditable. When you hit "Save and Publish", it reloads the grid and then it shows the box correctly. Anyone know how to fix that?

    In the doc type settings, the height for the RTE is defaulted to 500.

  • Brett Spencer 82 posts 251 karma points
    Nov 13, 2018 @ 16:27
    Brett Spencer
    0

    Yes, actually mine doesn't even show in Chrome. Umbraco Version 7.12.3.

    This isn't the first time its happened. I keep having to tell my editors its a bug and will be fixed. (But I don't know that for fact.)

    I don't use the grid often because of all these buggy features.

    Here's mine on load:

    enter image description here

    This is if I click on the whitespace (only because I know there is supposed to be an RTE there):

    enter image description here

    Still no text. So I when I click on the whitespace inside the RTE, I finally get what I should have seen when the page loaded:

    enter image description here

    Tried it in FireFox and Edge: I CAN see the text on load.

  • Nik 1142 posts 4730 karma points MVP 2x c-trib
    Nov 13, 2018 @ 16:47
    Nik
    0

    Hi Brett,

    Have you performed an upgrade recently for this to start happening?

    Nik

  • Brett Spencer 82 posts 251 karma points
    Nov 13, 2018 @ 17:11
    Brett Spencer
    0

    Hi Nik,

    No. Its a fresh install for a new site.

    Its happened for some time, it didn't just start.

    I hint to it in my previous post... I believe this is a chrome only issue.

    I just tested a different computer with Edge and Firefox and don't have the issue.

    Chrome and Umbraco have not been playing nice lately. I believe its all of the caching going on with each and they are "fighting each other".

  • ssougnez 85 posts 289 karma points c-trib
    Nov 13, 2018 @ 22:34
    ssougnez
    0

    Hi,

    I’m having the exact same issue and it is really starting to be annoying. I will dig in the code of Umbraco in the upcoming days to see if I can solve it somehow, although it’s hard to be sure as I don’t have this issue constantly, it’s erratic.

    I have this since 7.11.x (never installed any versions before that one).

  • Brett Spencer 82 posts 251 karma points
    Nov 13, 2018 @ 22:38
    Brett Spencer
    0

    I just added a "header" format in the RTE stylesheet and now it cuts off the content in Edge as well but only periodically.

    {
    font-family:'Roboto Slab', Roboto, Helvetica, Arial, sans-serif;
    font-size: 1.75rem;
    }
    
  • ssougnez 85 posts 289 karma points c-trib
    Nov 14, 2018 @ 11:30
    ssougnez
    0

    I just tried to reproduce the issue for 15 minutes now but I couldn't. I noticed that I was working with Umbraco 7.13, so I went on github and saw this.

    So I guess it's already fixed and will be available with 7.13 :-D

    So @Brett Spencer, you and I just have to wait a little bit more before being able to say to our content editors that it is fixed :-)

  • Dave Woestenborghs 3214 posts 10805 karma points MVP 4x admin c-trib
    Nov 14, 2018 @ 12:29
    Dave Woestenborghs
    0

    Hi all,

    If you can't wait for 7.13 to be released you can apply the fix manually if you want.

    Apply the changes from this PR in your local install: https://github.com/umbraco/Umbraco-CMS/pull/3232/files

    Make sure to clear Client Dependency cache after you made the changes

    Dave

Please Sign in or register to post replies

Write your reply to:

Draft