Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • manila 248 posts 550 karma points
    Aug 28, 2018 @ 10:54
    manila
    0

    Redirect URL Management not working

    I have version 7.6 of umbraco.

    I had previously Url Tracker installed (as a package) but currently have no dashboard any more and the Url Tracker is not any more on the list of my installed packages but it still works.

    When I rename a content it writes an entry in the database in icUrlTracker table. However when I go to the old url it shows 404 page instead of redirecting to the new one.

    I also have Redirect URl Management and renaming a content does not write an entry in umbracoRedirectUrl table.

    So basically Url tracker writes entries but not redirecting the old content.

    But Redirect URL Management does not work at all while I want this one to work and get rid of Url Tracker.

    I'm not sure why Redirect URL Management is not working, can it be any conflict with Url Tracker? What are files of Url Tracker I should look for and remove and how to check Redirect URL Management is installed correctly?

  • Marc Goodson 1023 posts 6752 karma points MVP 4x c-trib
    Aug 28, 2018 @ 11:55
    Marc Goodson
    100

    Hi manila

    Have a look in your /bin folder

    it sounds like you still have the UrlTracker dll present there (if changes are still being tracked to the database table)

    The presence of the dll 'turns off' the Redirect Url Management dashboard.

    So if you remove the dll called InfoCaster.Umbraco.UrlTracker.dll from the bin folder - that should work again for you.

    regards

    marc

  • Ravi Motha 278 posts 487 karma points MVP 3x c-trib
    Jan 29, 2019 @ 17:41
    Ravi Motha
    0

    Gotta follow-up , I'm getting the "classic" 404 from any of the old redirects on an inherited site..

    I've checked the configs.. I checked the packages and manifest

    no infocaster , SEOchecker, Terratype etc dlls ..

    i get a lot of

    Status code is 404 yet TrySkipIisCustomErrors is false - IIS will take over. So any ideas will help..

  • manila 248 posts 550 karma points
    Aug 28, 2018 @ 12:13
    manila
    0

    That's the case - I checked and had no InfoCaster dlls in my bin folder - in this branch at least. But checked Master branch and removed the dlls from its bin folder. Not sure why the current branch was not working of the dlls were not present but were present in the Master branch only.

    Anyway it worked, thanks Marc

  • Emmanuel Ramanyimi 19 posts 89 karma points
    Aug 13, 2019 @ 08:44
    Emmanuel Ramanyimi
    0

    Redirect URL Management is not work in mine, how did you fixed it

Please Sign in or register to post replies

Write your reply to:

Draft