Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • k 229 posts 593 karma points
    Sep 04, 2018 @ 08:59
    k
    0

    Umbraco crashing everytime I change document type

    Hello,

    Every time I am trying to add a field to document type the Umbraco crashes.

    Can someone please help.

    In log is can see the below error : 2017-12-11 17:09:38,618 [P6712/D2/T108] INFO Umbraco.Web.Scheduling.ScheduledTasks - test60 has been called with response: False 2017-12-11 17:10:38,618 [P6712/D2/T148] ERROR Umbraco.Web.Scheduling.ScheduledTasks - An error occurred calling web task for url: xxxxxxxx System.InvalidOperationException: An invalid request URI was provided. The request URI must either be an absolute URI or BaseAddress must be set. Thanks for helping.

    K

  • k 229 posts 593 karma points
    Sep 04, 2018 @ 10:43
    k
    0

    I did a test a gain and now got the below error :

    ERROR Umbraco.Web.Scheduling.KeepAlive - Failed (at "https://www.xxx.com:443/umbraco"). System.Threading.Tasks.TaskCanceledException: A task was canceled.
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Umbraco.Web.Scheduling.KeepAlive.

  • MuirisOG 371 posts 1259 karma points
    Sep 04, 2018 @ 10:48
    MuirisOG
    0

    You should probably check your permissions, especially to your app_data folder, and any sub-folders in there.

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 06:28
    k
    0

    Hello,

    where should I change the permissions please ?

    Thanks K

  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 05, 2018 @ 06:42
    Dave Woestenborghs
    0

    Hi K,

    Easiest way to check is to go into the developer section and then to the Health Checks dashboard.

    There is a check for permissions there. If you run that you can see if all your permissions are correct.

    Dave

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 06:52
    k
    0

    enter image description here

    Done. Seems ok.

    Is there anyhting else I can check.

    Thanks for helping.

  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 05, 2018 @ 06:56
    Dave Woestenborghs
    0

    Hi K,

    Can you fill in the umbracoApplicationUrl property with the Url of your website.

    https://our.umbraco.com/documentation/Reference/Config/umbracoSettings/#webrouting

    And see if the problem persists ?

    And as extra question. Are you using ModelsBuilder in your website. If so in which mode are you running it ?

    Dave

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 07:15
    k
    0

    Hello Dave,

    I tried :

     Can you fill in the umbracoApplicationUrl property with the Url of your website 
    

    and tried adding fields in my documentype and it crashes after adding two fields.

    I am using :

    <add key="Umbraco.ModelsBuilder.ModelsMode" value="PureLive" />
    
  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 05, 2018 @ 07:47
    Dave Woestenborghs
    100

    hi K

    Are you using the models generated by models build in your code ?

    If not, try to set the Umbraco.ModelsBuilder.ModelsMode to Nothing

    Dave

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 09:51
    k
    0

    Hello Dave,

    I tried it and it worked.

    Thank you very much for helping.

    Hopefully it wont crash again.

    K

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 10:30
    k
    0

    Hello Dave,

    But on all our sites we have

    <add key="Umbraco.ModelsBuilder.ModelsMode" value="PureLive" />
    

    But I do not have any issue with other websites.

    Do you know why ?

    Thanks,

    K

  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 05, 2018 @ 12:36
    Dave Woestenborghs
    0

    When you are using PureLive and change a doctype ModelsBuilders does complex stuff behind the scene to generate the models. This can explain for the website restart...But I can be wrong.

    Can you post what you have in your web.config for that httpRuntime tag and the compilation tag ?

    Dave

  • MuirisOG 371 posts 1259 karma points
    Sep 05, 2018 @ 13:16
    MuirisOG
    0

    We had problems on our live site after we changed a document type.

    The test site worked correctly.

    We narrowed it down to incorrect permissions to write to the all.dll.path file which sits in the following location: <site>\app_data\models\all.dll.path

    The problem seemed to happen because

    a) We changed the location of our temporary internet files in IIS, and

    b) Umbraco couldn't write the new location to the all.dll.path file after a recompile

    We copied the permissions used on our test site and this seemed to fix the problem.

    Thanks,

    Muiris

  • k 229 posts 593 karma points
    Sep 05, 2018 @ 13:39
    k
    0

    Please find below

     <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
    <httpRuntime executionTimeout="900" requestValidationMode="2.0" enableVersionHeader="false" targetFramework="4.5" maxRequestLength="51200" fcnMode="Single" />
    
     <compilation defaultLanguage="c#" batch="false" debug="true" targetFramework="4.5">
    
  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 05, 2018 @ 13:53
    Dave Woestenborghs
    0

    Hi K;

    This is what I have for httpRuntime a Umbraco 7.11 project

    <httpRuntime requestValidationMode="2.0" enableVersionHeader="false" targetFramework="4.5" maxRequestLength="51200" waitChangeNotification="3" maxWaitChangeNotification="10" fcnMode="Single" />
    

    Can you add the waitChangeNotification and maxWaitChangeNotification attributes

    And this is what i have for the compilatoin tag :

    <compilation defaultLanguage="c#" debug="false" batch="false" targetFramework="4.5" numRecompilesBeforeAppRestart="50">
    

    Maybe adding numRecompilesBeforeAppRestart attribute and changing debug to false will help

    Dave

  • k 229 posts 593 karma points
    Sep 07, 2018 @ 06:06
    k
    0

    Hello Dave,

    this tag : numRecompilesBeforeAppRestart="50" does it mean that after 50 manipulation the application pool will restart ?

    But it wont crash the site right ?

    I have added the option as you advised above. Also I wanted to ask should I revert back to

    <add key="Umbraco.ModelsBuilder.ModelsMode" value="PureLive" />
    

    Thanks for helping.

    K

  • Dave Woestenborghs 3203 posts 10697 karma points MVP 4x admin c-trib
    Sep 07, 2018 @ 06:38
    Dave Woestenborghs
    0

    You are right about the numRecompilesBeforeAppRestart attribute

    See explanation here : https://docs.microsoft.com/en-us/previous-versions/dotnet/netframework-4.0/s10awwz0(v=vs.100)

    So it probably will be save to set it back to PureLive

    But if you are not using the generated models in your views Nothing is fine as well

    Dave

Please Sign in or register to post replies

Write your reply to:

Draft