Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Adrian Wu 53 posts 266 karma points
    Sep 12, 2018 @ 10:22
    Adrian Wu
    0

    "Invite User" not working for Umbraco hosting at Azure App Service

    Hi, guys, I tried to use the "Invite User" for my Umbraco hosting on Azure App Service.

    But it says "Server error: Contact administrator, see log for full details. Failed to invite user".

    Is there anything I need to set up to get the email invitation working ?

    Thank you,

    A

  • Nik 1585 posts 7101 karma points MVP 6x c-trib
    Sep 12, 2018 @ 11:32
    Nik
    100

    Hi Adrian,

    Umbraco doesn't come with an SMTP server as part of it. So in order to get e-mailing working you will need a 3rd party SMTP server (or access to one). For example, you could set up a dedicated Gmail account and use Gmail as your SMTP server. There are quite a range of different SMTP providers around, a few of which I believe, work well with Azure hosted websites.

    In the web config file there is a section that looks like this:

    <system.net>
        <mailSettings>
          <smtp>
            <network host="127.0.0.1" userName="username" password="password" />
          </smtp>
        </mailSettings>
      </system.net> 
    

    Once you know your SMTP provider details you'll need to update these settings accordingly.

    Host is your SMTP server (for example smtp.gmail.com [not sure if that is the right one for google, but it's an example])

    UserName is your account username (for example mywebsitesemail@gmailcom)

    and Password is you account password.

    That should get you on the right path. Some additional settings do exist for Mail Settings and they can be seen here in the answers to this Stack overflow question :-) https://stackoverflow.com/questions/19233108/how-to-configure-smtp-settings-in-web-config

    Thanks,

    Nik

Please Sign in or register to post replies

Write your reply to:

Draft