Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Abdul Rahim 14 posts 84 karma points
    Sep 12, 2018 @ 13:07
    Abdul Rahim
    0

    This document is published but is not in the cache -- Publish At

    Hi Guys,

    I'm trying to use Publish at functionality in Umbraco. Everything is working fine and the page is published without any issues. The problem is, the published item is not visible in front end. It is showing This document is published but is not in the cache . Anyone please help?

    enter image description here

  • Paul Seal 465 posts 2554 karma points MVP 4x c-trib
    Sep 12, 2018 @ 14:21
    Paul Seal
    0

    Hi Abdul You should be able to resolve this by going to

    Developer > Examine tab > Internal Indexer > Rebuild Indexes

    Developer > Examine tab > External Indexer > Rebuild Indexes

    Kind regards

    Paul

  • Abdul Rahim 14 posts 84 karma points
    Sep 13, 2018 @ 04:23
    Abdul Rahim
    0

    Hi Paul,

    Thanks for your reply.

    Unfortunately, it wasn't worked.

    Thanks,

    Abdul

  • Greg Jenson 24 posts 157 karma points
    Sep 26, 2018 @ 20:53
    Greg  Jenson
    0

    Hi Paul, Abdul Have either come up with a solution for this? I'm running into the same issue, and have read every thread related to it, but can't find a solution.

    The only page that runs for me each day is the Home page. All others (which are directly Home) give me the same error as above every day. Even though the status still shows 'Published', I have to republish every day for these pages to load. Similarly, I have a 3 slide carousel running on the Home page, but slide 1 is doing the same as the rest of the pages - I have to republish that slide every day for it to display.

    I'm running Umbraco version 7.10.3, and this seems to be a long know issue, several threads indicating it's been resolved, but not for me apparently. Any help is welcome.

  • louisjrdev 107 posts 343 karma points c-trib
    Sep 27, 2018 @ 06:54
    louisjrdev
    1

    Hi Greg,

    Can you try ensuring that your App_Data/umbraco.config has the neccessary read/write permissions, i have had this before where it would drop out of the cache because it couldn't write to this file.

  • Greg Jenson 24 posts 157 karma points
    Sep 27, 2018 @ 19:23
    Greg  Jenson
    0

    Thanks for the suggestion, but unfortunately the permissions appear to be fine.

    UPDATE: I just republished the whole site, checked the log file and am getting the following:

    2018-10-09 13:11:54,139 [P4880/D2/T31] INFO  umbraco.content - Save Xml to file...
     2018-10-09 13:11:54,150 [P4880/D2/T31] ERROR umbraco.content - Failed to save Xml to file.
    System.UnauthorizedAccessException: Access to the path 'C:\inetpub\dev\App_Data\umbraco.config' is denied.
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.File.InternalDelete(String path, Boolean checkHost)
       at umbraco.content.SaveXmlToFile()
    

    I'm checking with my IT guys to see what we can figure out.

    Final Update: I had missed one permissions settings the first time. This has been found, corrected, and the site is working perfectly now. Thanks Louis!

  • girish 2 posts 71 karma points
    Jan 10, 2020 @ 11:28
    girish
    0

    In some cases we can solve this by rebuilding the indexes,

    Developer > Examine tab > Internal Indexer > Rebuild Indexes

    Developer > Examine tab > External Indexer > Rebuild Indexes

    If it's not working go with the bellow one,

    For this, you need access to the server. First clear the TEMP folder [solution\ App_Data\TEMP]. Then Restart the site and Recycle the Application Pool. If in case of the Temp file is not deletable, Please stop the site and then try.

    In my case, I solved this way. Hope this will help others too.

  • Kasper 5 posts 75 karma points
    1 week ago
    Kasper
    0

    For anyone still encountering this issue in 2021 - If you have models builder enabled, try building/rebuilding your models and restart the site. In my case, the nodes giving me problems where of a document type, for which I had not yet built models. While this seemed to do the trick for me, I did however also try the steps above, so you might have to rebuild indexes and reload memory caches as well etc.

Please Sign in or register to post replies

Write your reply to:

Draft