Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon 15 posts 85 karma points
    Dec 07, 2018 @ 07:48
    Simon
    0

    Different Language in URL

    Hi. We are facing a problem where our URL's have changed to not include ÆØÅ.

    Some of our pages is ÆØÅ and some are not. The Language is all DK in culture and hostnames settings. We can't seem to find where the error is. There is a lot of links that do not work now because of this change.

    Please see picture for example. enter image description here

  • Frans de Jong 462 posts 1585 karma points c-trib
    Dec 07, 2018 @ 09:11
    Frans de Jong
    0

    A simple solution is to change the name of the page. We always the name field (top of the page left of the actions button) for navigation and include a separate pagetitle in the content which contains the correct word for the language.

    The Url is generated with the name field so that shouldn't cause any trouble anymore.

    If this isn't the desired solution than I think you should alter the url provider to escape those characters.

  • MuirisOG 360 posts 1218 karma points
    Dec 10, 2018 @ 11:58
    MuirisOG
    0

    Perhaps you need to check the browsers language setting, which may in turn pick up the language setting of your PC.

  • Frans de Jong 462 posts 1585 karma points c-trib
    Dec 11, 2018 @ 07:28
    Frans de Jong
    0

    I always steer away from solving it on the PC. If this is a issue on his PC it can be a issue on anyone's PC right?

  • Simon 15 posts 85 karma points
    Dec 11, 2018 @ 08:14
    Simon
    0

    Hi

    its' on anyones PC.

    The problem is that we have a lot of links in our company documents and external documents where the links contain ÆØÅ. And all theese links won't work anymore.

    Thats why im concerned that there is some sort of setting on Umbraco or our IIS that has been changed.

  • Frans de Jong 462 posts 1585 karma points c-trib
    Dec 11, 2018 @ 08:17
    Frans de Jong
    0

    So just to get things straight; The url's worked before? On a certain moment all links stopped working?

  • Simon 15 posts 85 karma points
    Dec 11, 2018 @ 08:24
    Simon
    0

    yes correct!

    Now all the links only work without ÆØÅ. They did in fact work before.

  • Frans de Jong 462 posts 1585 karma points c-trib
    Dec 11, 2018 @ 12:04
    Frans de Jong
    0

    If you go to the info tab on a page using the special characters is there a link to the document?

  • MuirisOG 360 posts 1218 karma points
    Dec 11, 2018 @ 12:06
    MuirisOG
    0

    It could do no harm to check the localization settings on your IIS server.

Please Sign in or register to post replies

Write your reply to:

Draft