Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Connie DeCinko 3 posts 75 karma points
    1 week ago
    Connie DeCinko
    0

    Unable to Install via NuGet

    I can download the zip version and set it up, works just fine. However I want to use the UIntra package and it won't install. So, as a test, I tried to install just Umbraco via NuGet, clean empty project, just like the instructions. Tried version 7.12.x yesterday and 7.13 today. Same thing, errors and more errors. I get the Readme at the end. I hit Build and get this error...

    1>------ Build started: Project: Umbraco, Configuration: Debug Any CPU ------
    1>CSC : warning AD0001: Analyzer 'Microsoft.CodeAnalysis.CSharp.Analyzers.FixAnalyzers.CSharpFixerWithFixAllAnalyzer' thr
    1>ew an exception of type 'System.TypeInitializationException' with message 'The type initializer for 'Microsoft.CodeAnal
    1>ysis.Analyzers.FixAnalyzers.FixerWithFixAllAnalyzer`1' threw an exception.'.
    1>  Umbraco -> C:\Sandbox\Umbraco\Umbraco\bin\Umbraco.dll
    ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    

    I hit F5 and get this error:

        Parser Error
    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. 
    
    Parser Error Message: Could not load type 'Umbraco.Web.UmbracoApplication'.
    
    Source Error: 
    
    
    Line 1:  <%@ Application Inherits="Umbraco.Web.UmbracoApplication" Language="C#" %>
    Line 2:            
    
    Source File: /global.asax    Line: 1 
    

    What is wrong?

  • Alex Skrypnyk 4886 posts 17639 karma points MVP 2x admin c-trib
    1 week ago
    Alex Skrypnyk
    0

    Hi Connie

    I would suggest you move this question to UIntra issues tracker - https://github.com/Uintra/Uintra/issues

    Alex

  • Connie DeCinko 3 posts 75 karma points
    1 week ago
    Connie DeCinko
    2

    First issue resolved by upgrading the analyzer. Default is ver. 1.0.

    Second is same issue that can cause an Umbraco project to fail... you cannot name your VS project Umbraco or your UIntra project UIntra. You end up creating a naming conflict that does not resolve. Recreated using a different name for the project and now it works.

  • John Bergman 386 posts 926 karma points
    7 days ago
    John Bergman
    0

    What version did you upgrade to?

  • Connie DeCinko 3 posts 75 karma points
    5 days ago
    Connie DeCinko
    0

    Whatever the latest version is. I want to say 3.x?

Please Sign in or register to post replies

Write your reply to:

Draft