Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Giacomo De Liberali 5 posts 75 karma points
    5 days ago
    Giacomo De Liberali
    0

    Disable cache during development

    During development using Visual Studio, each time I edit a view the changes do not reflect in Umbraco since it uses caching mechanisms. So every time I have to hit the save button (in the same view) in the backoffice in order to refresh the cache and see changes appearing. I tried to disable the flag in the umbracoSettings.config but, even after a clean rebuild, I still see the outdated views, so the flag seems to not influence the cache manager.

    Here's an extract of my umbracoSettings.config:

    <settings> <content> <XmlCacheEnabled>False</XmlCacheEnabled> </content> </settings>

    How can I resolve this frustrating issue?

  • Nik 935 posts 3743 karma points MVP c-trib
    5 days ago
    Nik
    0

    Hi Giacomo,

    I'm not sure exactly on the issue you are having, but the cache you'd disabled is related to the content cache rather than any view caching that may be in place. The XML cache is a cache of the content you enter in Umbraco but doesn't contain any of your Partial view information.

    Do you have something like Donut Caching, or are you using Html.CachedPartials (or another caching approach) ?

    Nik

  • Giacomo De Liberali 5 posts 75 karma points
    5 days ago
    Giacomo De Liberali
    0

    No I'm not using any caching approach, just a fresh install with some basic document types and content. Does Umbraco use any caching for the views?

  • Nik 935 posts 3743 karma points MVP c-trib
    5 days ago
    Nik
    0

    Hi Giacomo,

    Not that I'm aware of. What sort of Visual Studio project are you using? is it a Website Project or a Web Application project?

    Nik

  • Giacomo De Liberali 5 posts 75 karma points
    5 days ago
    Giacomo De Liberali
    0

    It should be a Website Project, generated from the UaaS-cmd

  • Matthew Wise 125 posts 486 karma points c-trib
    5 days ago
    Matthew Wise
    0

    Hi,

    Are you running in debug?

    If not and you are using cached partials or macros that could be the cause.

    Also do you have output cache enabled? If so set it to false

    <system.web>        
        <caching>
            <outputCache enableOutputCache="true"  />
        </caching>
    </system.web>
    

    Matt

  • Giacomo De Liberali 5 posts 75 karma points
    5 days ago
    Giacomo De Liberali
    0

    Yes, I've tried also in debug but the issue remains. I'm not using cached partials, indeed this problem occurs also in regular templates.

    I haven't the output cache enabled (it was missing in the web config). Also putting it to false does not change the behaviour.

    It's the fresh solution generated by the Uaas, since I'm using Umbraco Cloud.

    I'm working in a virtual machine over Parallels if it could help to investigate the scenario.

  • Giacomo De Liberali 5 posts 75 karma points
    2 days ago
    Giacomo De Liberali
    0

    Any further suggestion? The problem isn't solved yet :(

    Maybe I can try to clone the project to remove cache folders. I will let you know

Please Sign in or register to post replies

Write your reply to:

Draft