Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Carlos Mosqueda 239 posts 429 karma points
    Jan 15, 2019 @ 19:04
    Carlos Mosqueda

    Getting JS errors in the admin when trying to select Unpublish date - Umbraco 7.12.1

    We are running into issues with our admins having problems selecting a publish or unpublish date.

    When we try to select the an unpublish date, we are getting

    "TypeError: moment.utc(...).utcOffset is not a function"

    Errors in the console and the unpublish date is not getting selected.

    I am also getting

    "Error: Duplicates in a repeater are not allowed. Repeater: url in node.urls key:"

    What could be causing this. Our editors can't select unpublish dates currently.

  • Jan Skovgaard 11264 posts 23595 karma points MVP 9x admin c-trib
    Jan 18, 2019 @ 22:27
    Jan Skovgaard

    Hi Carlos

    Did you have any luck figuring this issue out? I'm wondering what language your backoffice is running? Is it English by default or some other language? I'm wondering if the language is not English if perhaps it can then be a bug related to handling of the dates somehow.


  • David Amri 214 posts 740 karma points
    Jan 25, 2019 @ 06:47
    David Amri

    I'm getting a similar error when trying to add more than one domain in "Culture and hostnames"?

    Error: Duplicates in a repeater are not allowed. Repeater: url in node.urls key: string:

    When adding the second domain the urls will not show in the "Info" tab of each node? Really need some help with this...


  • Carlos Mosqueda 239 posts 429 karma points
    Jan 25, 2019 @ 12:53
    Carlos Mosqueda

    Hi Jan,

    Actually I ran into the same issue Davis was having as well getting the repeater error, I posted that as a separate forum question yesterday. Not sure if they are related bor not. The site is set to inherit. I think it is just default for the language.

    I get the repeater issue if I have something like, and (which we need) configured in our Culture and Hostname, and I am wondering if this is causing a JS error cascade affect with the time picker.
    I was also messing with the permissions a bunch and may or may have found that the permissions to Audit History caused an in ability to set the unpublish date. That may have just been coincidence though.

    But definitely seeing the 2 domain issue and not seeing the links in the info tab.

  • Carlos Mosqueda 239 posts 429 karma points
    Jan 30, 2019 @ 20:20
    Carlos Mosqueda

    @Umbraco, any ideas?

  • Nicholas Westby 2045 posts 7034 karma points c-trib
    Jun 08, 2019 @ 00:59
    Nicholas Westby

    The "duplicates in repeater" error will be fixed in Umbraco 7.15.0: FYI, the fix for this is due in Umbraco 7.15.0:

    I doubt this has to do with your unpublish date issue though.

  • Craig100 1120 posts 2474 karma points c-trib
    Feb 03, 2020 @ 11:49

    Umb 7.15.3

    I'm getting the utcOffset issue every time I click on "Set date" or one of it's windows. Therefore can't set Publish/Unpublish dates:-

    enter image description here

    I've tried copying Umbraco and UmbracoClient folders from source over the project's ones but that's made no difference.

    Any advice would be appreciated.

    // Craig

  • Craig100 1120 posts 2474 karma points c-trib
    Feb 03, 2020 @ 12:33

    Answering my own query in case it helps someone else....

    My issue was caused by a plugin loading an old version of moment.js. The order in which it loaded meant the plugin version 2.8.2 over-wrote Umbraco's version 2.13.0. Removing the plugin fixed the utcOffset issue :)

    // Craig

Please Sign in or register to post replies

Write your reply to: