Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Thomas Moltzen-Bildsøe 10 posts 130 karma points
    Jan 18, 2019 @ 10:48
    Thomas Moltzen-Bildsøe
    0

    Language customization ignored in 7.13.1

    Hi All

    I just upgraded to Umbraco 7.13.1 - and the language-overwrites doesn't work (actually I don't now if they did previously, because this is the first time i tried using them). Does this happen to you also?

    I set my default language in web.config using (this works):

    <add key="umbracoDefaultUILanguage" value="da" />
    

    Then I try to overwrite some of the sentences in \Config\Lang\da-DK.user.xml.

    Like so:

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <language>
      <area alias="login">
        <key alias="greeting0">Login til Umbraco</key>
        <key alias="greeting1">Login til Umbraco</key>
        <key alias="greeting2">Login til Umbraco</key>
        <key alias="greeting3">Login til Umbraco</key>
        <key alias="greeting4">Login til Umbraco</key>
        <key alias="greeting5">Login til Umbraco</key>
        <key alias="greeting6">Login til Umbraco</key>
      </area>
    </language>
    

    I've tried restarting the site. But nothing happens - the overwrites simple doesn't show.

    BR Thomas

  • Jan Skovgaard 11232 posts 23315 karma points MVP 6x admin c-trib
    Jan 18, 2019 @ 22:16
    Jan Skovgaard
    0

    Hi Thomas

    I'm wondering if changing the umbracoDefaultUILanguge is actually enough? I mean... The user you created when installing Umbraco initially is probably still setup to use the english language, which might be why you're not seeing the changes? I have not double checked my suspicion on a clean installation but I'm wondering if this could in fact be the issue in your case?

    Hope it makes sense!

    /Jan

  • Thomas Moltzen-Bildsøe 10 posts 130 karma points
    Jan 18, 2019 @ 22:19
    Thomas Moltzen-Bildsøe
    0

    I also tried adding it to en-US and en-GB as well. Just in case :) but still same result. Nothing happens.

  • Jan Skovgaard 11232 posts 23315 karma points MVP 6x admin c-trib
    Jan 18, 2019 @ 23:11
    Jan Skovgaard
    1

    Hi Thomas

    Ok that is odd - I just installed a fresh version of 7.13.1 and when I change the /config/lang/en-US.user.xml adding the same content as you mention above

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <language>
        <area alias="login">
            <key alias="greeting0">Login to Umbraco</key>
            <key alias="greeting1">Login to Umbraco </key>
            <key alias="greeting2">Login to Umbraco</key>
            <key alias="greeting3">Login to Umbraco</key>
            <key alias="greeting4">Login to Umbraco</key>
            <key alias="greeting5">Login to Umbraco</key>
            <key alias="greeting6">Login to Umbraco</key>
        </area>
    </language>
    

    Then it works fine when I have touched the web.config and refresh the login screen.

    However I started out byt setting debug to true in the web.config before experimenting with the settings. This line, for any future reference <compilation defaultLanguage="c#" debug="false" batch="true" targetFramework="4.5" numRecompilesBeforeAppRestart="50"> was changed to <compilation defaultLanguage="c#" debug="true" batch="true" targetFramework="4.5" numRecompilesBeforeAppRestart="50">

    So I'm wondering if it's because of caching that you don't see the changes. What happens if you bump the /config/clientDependency.config's version number and touch the web.config? Does it work then?

    /Jan

  • Thomas Moltzen-Bildsøe 10 posts 130 karma points
    Jan 21, 2019 @ 07:58
    Thomas Moltzen-Bildsøe
    100

    Hi Jan

    I had turned debug on from start. And have tried touching web.config and also increasing in clientDependency.config to no effect.

    Also I've tried with and without "area" and still nothing.

    And tried going under Devtools\Application and deleting everything in Chrome. Nothing.

    But then I noticed this (perhaps obsolete, I recently upgraded all the way from 6.1.6 - in steps) key:

    <add key="umbracoDebugMode" value="false" />
    

    Tried changing it to true, and it worked.

  • Jan Skovgaard 11232 posts 23315 karma points MVP 6x admin c-trib
    Jan 21, 2019 @ 08:15
    Jan Skovgaard
    0

    Hi Thomas

    Ah, nice find! I really should have asked if you had done any upgrades - But happy to see you got it sorted :)

    /Jan

  • Thomas Moltzen-Bildsøe 10 posts 130 karma points
    Jan 21, 2019 @ 08:34
    Thomas Moltzen-Bildsøe
    0

    Thanks for the help Jan :)

    The setting is not included here: https://our.umbraco.com/documentation/Reference/Config/webconfig/ on the list of settings for V.7, but it still has an effect. Can I remove it completely or is it actually needed. I'm mostly asking because I want to clean up my web.config's. I have 50 sites I need to do the same things for.

    BR Thomas

  • Jan Skovgaard 11232 posts 23315 karma points MVP 6x admin c-trib
    Jan 22, 2019 @ 06:13
    Jan Skovgaard
    0

    Hi Thomas

    I think you will need to keep the setting but I honestly don't know for sure :)

    Hmm, yeah I guess it should be added to the documentation - Do you feel like doing a PR adding it? Otherwise I'll be happy to give it a shot.

    Cheers, Jan

Please Sign in or register to post replies

Write your reply to:

Draft